CVE-2019-14772
Cross-Site Scripting (XSS) in Verdaccio
verdaccio before 3.12.0 allows XSS.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
verdaccio before 3.12.0 allows XSS.
- Record
CVE-2019-14772- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
verdaccio before 3.12.0 allows XSS.
- Record
CVE-2019-14772- Updated
- 2026-11-02
EUVDEUVD-2019-0457 No score
verdaccio before 3.12.0 allows XSS.
- Record
EUVD-2019-0457- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-78j5-gcmf-vqc8
6.1
Cross-Site Scripting (XSS) in Verdaccio
Impact
What kind of vulnerability is it? Who is impacted?
Cross-Site Scripting XSS, malicious packages with content Javascript that might be executed in the User Interface stealing user credentials.
Patches
Has the problem been patched? What versions should users upgrade to?
Users that still using v3 must upgrade to >3.12.0 or those have no problem to migrate to a major version >=4.0.0 also fix the issue.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
No, the users must update.
References
Are there any links users can visit to find out more?
https://www.npmjs.com/advisories/832 https://www.npmjs.com/advisories/833
The issue was reported by the NPMJS Security Team
For more information
If you have any questions or comments about this advisory:
- Read the Security Policy to find the ways to be in contact with us.
- Record
GHSA-78j5-gcmf-vqc8- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
verdaccio before 3.12.0 allows XSS.
- Record
CVE-2019-14772- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-78j5-gcmf-vqc8
6.1
Cross-Site Scripting (XSS) in Verdaccio
Impact
What kind of vulnerability is it? Who is impacted?
Cross-Site Scripting XSS, malicious packages with content Javascript that might be executed in the User Interface stealing user credentials.
Patches
Has the problem been patched? What versions should users upgrade to?
Users that still using v3 must upgrade to >3.12.0 or those have no problem to migrate to a major version >=4.0.0 also fix the issue.
Workarounds
Is there a way for users to fix or remediate the vulnerability without upgrading?
No, the users must update.
References
Are there any links users can visit to find out more?
https://www.npmjs.com/advisories/832 https://www.npmjs.com/advisories/833
The issue was reported by the NPMJS Security Team
For more information
If you have any questions or comments about this advisory:
- Read the Security Policy to find the ways to be in contact with us.
- Record
GHSA-78j5-gcmf-vqc8- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
verdaccionpm |
before 3.12.0 | 3.12.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-14772 is a medium vulnerability (CVSS 6.1) in Verdaccio, published May 29, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.86%, the 58th percentile. Fixed in verdaccio 3.12.0.