Every CVE Search/ Get API key

CVE-2019-14819

A flaw was found during the upgrade of an existing OpenShift Container Platform 3.x cluster....

7.5 HighFix available

A flaw was found during the upgrade of an existing OpenShift Container Platform 3.x cluster. Using CRI-O, the dockergc service account is assigned to the current namespace of the user performing the upgrade. This flaw can allow an unprivileged user to escalate their privileges to those allowed by the privileged Security Context Constraints.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.07%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.5

A flaw was found during the upgrade of an existing OpenShift Container Platform 3.x cluster. Using CRI-O, the dockergc service account is assigned to the current namespace of the user performing the upgrade. This flaw can allow an unprivileged user to escalate their privileges to those allowed by the privileged Security Context Constraints.

Record
CVE-2019-14819
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-266, CWE-270
Updated
2026-11-02
EUVDEUVD-2019-5948 7.5

A flaw was found during the upgrade of an existing OpenShift Container Platform 3.x cluster. Using CRI-O, the dockergc service account is assigned to the current namespace of the user performing the upgrade. This flaw can allow an unprivileged user to escalate their privileges to those allowed by the privileged Security Context Constraints.

Record
EUVD-2019-5948
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-37jw-xgjq-3fmq 8.8

A flaw was found during the upgrade of an existing OpenShift Container Platform 3.x cluster....

A flaw was found during the upgrade of an existing OpenShift Container Platform 3.x cluster. Using CRI-O, the dockergc service account is assigned to the current namespace of the user performing the upgrade. This flaw can allow an unprivileged user to escalate their privileges to those allowed by the privileged Security Context Constraints.

Record
GHSA-37jw-xgjq-3fmq
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-266, CWE-269
Updated
2026-11-02
NVD 8.8

A flaw was found during the upgrade of an existing OpenShift Container Platform 3.x cluster. Using CRI-O, the dockergc service account is assigned to the current namespace of the user performing the upgrade. This flaw can allow an unprivileged user to escalate their privileges to those allowed by the privileged Security Context Constraints.

Record
CVE-2019-14819
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-266, CWE-270, CWE-269
Updated
2026-11-02
OSVRHSA-2019:2818 7.5

Red Hat Security Advisory: OpenShift Container Platform 3.11 security update

Record
RHSA-2019:2818
CVSS 3.0
7.5 HighCVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openshift-ansible
Red Hat:openshift:3.11::el7
before 0:3.11.146-1.git.0.fcedb45.el7
0:3.11.146-1.git.0.fcedb45.el7
openshift-ansible-docs
Red Hat:openshift:3.11::el7
before 0:3.11.146-1.git.0.fcedb45.el7
0:3.11.146-1.git.0.fcedb45.el7
openshift-ansible-playbooks
Red Hat:openshift:3.11::el7
before 0:3.11.146-1.git.0.fcedb45.el7
0:3.11.146-1.git.0.fcedb45.el7
openshift-ansible-roles
Red Hat:openshift:3.11::el7
before 0:3.11.146-1.git.0.fcedb45.el7
0:3.11.146-1.git.0.fcedb45.el7
openshift-ansible-test
Red Hat:openshift:3.11::el7
before 0:3.11.146-1.git.0.fcedb45.el7
0:3.11.146-1.git.0.fcedb45.el7

History

History
RecordedChangedSources
aliases, productsEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-14819 is a high vulnerability (CVSS 7.5) in Redhat Openshift Container Platform, published January 7, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.07%, the 65th percentile. Fixed in openshift-ansible 0:3.11.146-1.git.0.fcedb45.el7.

References

MoveEnter Open