CVE-2019-15058
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in stbi__tga_load,...
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in stbi__tga_load, leading to Information Disclosure or Denial of Service.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.1
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in stbi__tga_load, leading to Information Disclosure or Denial of Service.
- Record
CVE-2019-15058- CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - CVSS 2.0
- 6.4 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in stbi__tga_load, leading to Information Disclosure or Denial of Service.
- Record
CVE-2019-15058- Updated
- 2026-11-02
EUVDEUVD-2019-6142 No score
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in stbi__tga_load, leading to Information Disclosure or Denial of Service.
- Record
EUVD-2019-6142- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-77mw-2mfc-5cxm
9.1
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in stbi__tga_load,...
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in stbi__tga_load, leading to Information Disclosure or Denial of Service.
- Record
GHSA-77mw-2mfc-5cxm- CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
9.1
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in stbi__tga_load, leading to Information Disclosure or Denial of Service.
- Record
CVE-2019-15058- CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-15058
9.1
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in stbi__tga_load, leading to Information Disclosure or Denial of Service.
- Record
DEBIAN-CVE-2019-15058- CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-15058
9.1
stb_image.h (aka the stb image loader) 2.23 has a heap-based buffer over-read in stbi__tga_load, leading to Information Disclosure or Denial of Service.
- Record
UBUNTU-CVE-2019-15058- CVSS 3.0
- 9.1 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libstbDebian:12 |
before 0.0~git20210910.af1a5bc+ds-1 | 0.0~git20210910.af1a5bc+ds-1 |
libstbDebian:13 |
before 0.0~git20210910.af1a5bc+ds-1 | 0.0~git20210910.af1a5bc+ds-1 |
libstbDebian:14 |
before 0.0~git20210910.af1a5bc+ds-1 | 0.0~git20210910.af1a5bc+ds-1 |
libstbUbuntu:20.04:LTS |
All versions, plus listed versions 0.0~git20190817.1.052dce1-1 |
None known |
libstbUbuntu:22.04:LTS |
All versions, plus listed versions 0.0~git20200713.b42009b+ds-10.0~git20210910.af1a5bc+ds-1 |
None known |
libstbUbuntu:24.04:LTS |
All versions, plus listed versions 0.0~git20230129.5736b15+ds-10.0~git20230129.5736b15+ds-1.10.0~git20230129.5736b15+ds-1.2 |
None known |
libstbUbuntu:25.10 |
All versions, plus listed versions 0.0~git20240715.f7f20f39fe4f+ds-10.0~git20241109.5c20573+ds-1 |
None known |
libstbUbuntu:26.10 |
All versions, plus listed versions 0.0~git20250907.fede005+ds-1 |
None known |
libstbUbuntu:26.04:LTS |
All versions, plus listed versions 0.0~git20241109.5c20573+ds-10.0~git20250907.fede005+ds-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-15058 is a critical vulnerability (CVSS 9.1) in Stb Project Stb, published August 14, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.80%, the 86th percentile. Fixed in libstb 0.0~git20210910.af1a5bc+ds-1.