Every CVE Search/ Get API key

CVE-2019-15163

rpcapd/daemon.c in libpcap before 1.9.1 allows attackers to cause a denial of service (NULL...

7.5 HighFix available

rpcapd/daemon.c in libpcap before 1.9.1 allows attackers to cause a denial of service (NULL pointer dereference and daemon crash) if a crypt() call fails.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

4.44%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

rpcapd/daemon.c in libpcap before 1.9.1 allows attackers to cause a denial of service (NULL pointer dereference and daemon crash) if a crypt() call fails.

Record
CVE-2019-15163
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-476
Updated
2026-11-02
CVE List No score

rpcapd/daemon.c in libpcap before 1.9.1 allows attackers to cause a denial of service (NULL pointer dereference and daemon crash) if a crypt() call fails.

Record
CVE-2019-15163
Updated
2026-11-02
EUVDEUVD-2019-6219 No score

rpcapd/daemon.c in libpcap before 1.9.1 allows attackers to cause a denial of service (NULL pointer dereference and daemon crash) if a crypt() call fails.

Record
EUVD-2019-6219
Updated
2026-11-03
GitHub AdvisoriesGHSA-8f74-v8w6-4296 7.5

rpcapd/daemon.c in libpcap before 1.9.1 allows attackers to cause a denial of service (NULL...

rpcapd/daemon.c in libpcap before 1.9.1 allows attackers to cause a denial of service (NULL pointer dereference and daemon crash) if a crypt() call fails.

Record
GHSA-8f74-v8w6-4296
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-476
Updated
2026-11-02
OSVALPINE-CVE-2019-15163 7.5

rpcapd/daemon.c in libpcap before 1.9.1 allows attackers to cause a denial of service (NULL pointer dereference and daemon crash) if a crypt() call fails.

Record
ALPINE-CVE-2019-15163
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVBELL-CVE-2019-15163 7.5

CVE-2019-15163 does not affect BellSoft software

Record
BELL-CVE-2019-15163
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV 7.5

rpcapd/daemon.c in libpcap before 1.9.1 allows attackers to cause a denial of service (NULL pointer dereference and daemon crash) if a crypt() call fails.

Record
CVE-2019-15163
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-15163 7.5

rpcapd/daemon.c in libpcap before 1.9.1 allows attackers to cause a denial of service (NULL pointer dereference and daemon crash) if a crypt() call fails.

Record
DEBIAN-CVE-2019-15163
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVMGASA-2019-0297 No score

Updated libpcap and tcpdump packages fix security vulnerabilities

Updated libpcap and tcpdump packages fix security vulnerabilities:

The libpcap packages have been updated to versions 1.9.1 and tcpdump to 4.9.3, respectively, fixing several buffer overread and overflow issues.

Record
MGASA-2019-0297
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libpcap
Alpine:v3.10
before 1.1.1-r0
1.1.1-r0
libpcap
Alpine:v3.12
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.13
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.14
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.15
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.16
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.17
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.18
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.19
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.20
before 1.9.1-r0
1.9.1-r0
Show 9 moreShow less
Affected packages
PackageAffectedFixed
libpcap
Alpine:v3.21
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.22
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.23
before 1.9.1-r0
1.9.1-r0
libpcap
Alpine:v3.24
before 1.9.1-r0
1.9.1-r0
libpcap
Debian:12
before 1.9.1-1
1.9.1-1
libpcap
Debian:13
before 1.9.1-1
1.9.1-1
libpcap
Debian:14
before 1.9.1-1
1.9.1-1
libpcap
Mageia:7
From an advisory covering 32 CVEs
before 1.9.1-1.mga7
1.9.1-1.mga7
tcpdump
Mageia:7
From an advisory covering 32 CVEs
before 4.9.3-1.mga7
4.9.3-1.mga7

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-15163 is a high vulnerability (CVSS 7.5) in Tcpdump Libpcap, published October 3, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.44%, the 91st percentile. Fixed in libpcap 1.1.1-r0.

References

Show 17 moreShow less
MoveEnter Open