Every CVE Search/ Get API key

CVE-2019-15477

Cross-site Scripting in Jooby

6.1 MediumPublic exploitFix available

Jooby before 1.6.4 has XSS via the default error handler.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.98%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

Jooby before 1.6.4 has XSS via the default error handler.

Record
CVE-2019-15477
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Jooby before 1.6.4 has XSS via the default error handler.

Record
CVE-2019-15477
Updated
2026-11-02
EUVDEUVD-2019-0631 No score

Jooby before 1.6.4 has XSS via the default error handler.

Record
EUVD-2019-0631
Updated
2026-11-03
GitHub AdvisoriesGHSA-f5f4-m7qp-w6gc 6.1

Cross-site Scripting in Jooby

Jooby before 1.6.4 has XSS via the default error handler.

Record
GHSA-f5f4-m7qp-w6gc
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Jooby before 1.6.4 has XSS via the default error handler.

Record
CVE-2019-15477
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-f5f4-m7qp-w6gc 6.1

Cross-site Scripting in Jooby

Jooby before 1.6.4 has XSS via the default error handler.

Record
GHSA-f5f4-m7qp-w6gc
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
org.jooby:jooby
Maven
before 1.6.4
1.6.4
org.jooby:jooby
Maven
before 1.6.4, plus listed versions
0.1.00.10.00.11.00.11.10.11.2
Show 45 moreShow less
0.12.00.13.00.13.10.14.00.15.00.15.10.16.00.2.00.2.10.3.00.4.00.4.10.4.20.4.2.10.5.00.5.10.5.20.5.30.6.00.6.10.6.20.6.30.6.40.7.00.8.00.8.10.8.20.9.00.9.10.9.21.0.01.0.0.CR11.0.0.CR21.0.0.CR31.0.0.CR41.0.0.CR51.0.0.CR61.0.0.CR71.0.0.CR81.0.11.0.21.0.31.1.01.1.11.1.2
1.6.4

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubepicosy/jooby2024-05-31

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-15477 is a medium vulnerability (CVSS 6.1) in Jooby, published August 23, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 0.98%, the 62nd percentile. Fixed in org.jooby:jooby 1.6.4.

References

This page doesn't list everything

Left out here: 14 versions. The JSON record has them.

MoveEnter Open