Every CVE Search/ Get API key

CVE-2019-15479

Status Board vulnerable to Cross-Site Scripting before v1.1.82

6.1 MediumFix available

Status Board 1.1.81 has reflected XSS via dashboard.ts.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.84%Down 1.0 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

Status Board 1.1.81 has reflected XSS via dashboard.ts.

Record
CVE-2019-15479
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Status Board 1.1.81 has reflected XSS via dashboard.ts.

Record
CVE-2019-15479
Updated
2026-11-02
EUVDEUVD-2019-0659 No score

Status Board 1.1.81 has reflected XSS via dashboard.ts.

Record
EUVD-2019-0659
Updated
2026-11-03
GitHub AdvisoriesGHSA-8864-rhmw-5m6f 6.1

Status Board vulnerable to Cross-Site Scripting before v1.1.82

Versions of status-board prior to 1.1.82 are vulnerable to Cross-Site Scripting. The renderDashboard() function concatenates the safeDashboard variable to the printed error message with insufficient sanitization. If this variable is controlled by user input it allows attackers to execute arbitrary JavaScript in a victim's browser.

Recommendation

Upgrade to version 1.1.82 to receive a patch.

Record
GHSA-8864-rhmw-5m6f
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.1

Status Board 1.1.81 has reflected XSS via dashboard.ts.

Record
CVE-2019-15479
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-8864-rhmw-5m6f 6.1

Status Board vulnerable to Cross-Site Scripting before v1.1.82

Versions of status-board prior to 1.1.82 are vulnerable to Cross-Site Scripting. The renderDashboard() function concatenates the safeDashboard variable to the printed error message with insufficient sanitization. If this variable is controlled by user input it allows attackers to execute arbitrary JavaScript in a victim's browser.

Recommendation

Upgrade to version 1.1.82 to receive a patch.

Record
GHSA-8864-rhmw-5m6f
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
status-board
npm
before 1.1.82
1.1.82

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-15479 is a medium vulnerability (CVSS 6.1) in Status Board Project Board, published August 26, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.84%, the 58th percentile. Fixed in status-board 1.1.82.

References

MoveEnter Open