CVE-2019-15481
Kimai v2 is vulnerable to Cross-Site Scripting (XSS)
Kimai v2 before 1.1 has XSS via a timesheet description.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Kimai v2 before 1.1 has XSS via a timesheet description.
- Record
CVE-2019-15481- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Kimai v2 before 1.1 has XSS via a timesheet description.
- Record
CVE-2019-15481- Updated
- 2026-11-02
EUVDEUVD-2022-3061 No score
Kimai v2 before 1.1 has XSS via a timesheet description.
- Record
EUVD-2022-3061- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7v44-75jf-22gj
6.1
Kimai v2 is vulnerable to Cross-Site Scripting (XSS)
Kimai v2 before 1.1 has XSS via a timesheet description.
- Record
GHSA-7v44-75jf-22gj- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Kimai v2 before 1.1 has XSS via a timesheet description.
- Record
CVE-2019-15481- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-7v44-75jf-22gj
6.1
Kimai v2 is vulnerable to Cross-Site Scripting (XSS)
Kimai v2 before 1.1 has XSS via a timesheet description.
- Record
GHSA-7v44-75jf-22gj- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
kevinpapst/kimai2Packagist |
before 1.1 | 1.1 |
kevinpapst/kimai2Packagist |
before 1.1, plus listed versions 0.10.20.30.40.5 Show 8 moreShow less0.60.6.10.70.80.8.10.91.01.0.1 |
1.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-15481 is a medium vulnerability (CVSS 6.1) in Kimai 2, published August 23, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.86%, the 58th percentile. Fixed in kevinpapst/kimai2 1.1.