CVE-2019-15531
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function...
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
6.5
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.
- Record
CVE-2019-15531- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:N/A:P - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.
- Record
CVE-2019-15531- Updated
- 2026-11-02
EUVDEUVD-2019-6516 No score
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.
- Record
EUVD-2019-6516- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m4hp-jj52-f756
6.5
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function...
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.
- Record
GHSA-m4hp-jj52-f756- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Weakness
- CWE-125
- Updated
- 2026-11-02
OSV
6.5
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.
- Record
CVE-2019-15531- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-15531
6.5
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.
- Record
DEBIAN-CVE-2019-15531- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-15531
6.5
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c.
- Record
UBUNTU-CVE-2019-15531- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVMGASA-2020-0015 No score
Updated libextractor packages fix security vulnerability
Updated libextractor packages fix security vulnerability:
GNU Libextractor through 1.9 has a heap-based buffer over-read in the function EXTRACTOR_dvi_extract_method in plugins/dvi_extractor.c (CVE-2019-15531).
- Record
MGASA-2020-0015- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libextractorDebian:12 |
before 1:1.9-2 | 1:1.9-2 |
libextractorDebian:13 |
before 1:1.9-2 | 1:1.9-2 |
libextractorDebian:14 |
before 1:1.9-2 | 1:1.9-2 |
libextractorDebian:8 |
before 1:1.3-2+deb8u5, plus listed versions 1:1.3-21:1.3-2+deb8u11:1.3-2+deb8u21:1.3-2+deb8u31:1.3-2+deb8u4 |
1:1.3-2+deb8u5 |
libextractorDebian:9 |
before 1:1.3-4+deb9u4, plus listed versions 1:1.3-41:1.3-4+deb9u11:1.3-4+deb9u21:1.3-4+deb9u3 |
1:1.3-4+deb9u4 |
libextractorMageia:7 |
before 1.9-2.1.mga7 | 1.9-2.1.mga7 |
libextractorUbuntu:Pro:14.04:LTS |
before 1:1.3-1ubuntu0.1~esm1, plus listed versions 1:1.1-1ubuntu11:1.2-1ubuntu11:1.3-1 |
1:1.3-1ubuntu0.1~esm1 |
libextractorUbuntu:16.04:LTS |
All versions, plus listed versions 1:1.3-2build11:1.3-2ubuntu11:1.3-31:1.3-4+deb9u3build0.16.04.1 |
None known |
libextractorUbuntu:18.04:LTS |
All versions, plus listed versions 1:1.3-4build31:1.6-11:1.6-1build11:1.6-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-15531 is a medium vulnerability (CVSS 6.5) in Gnu Libextractor, published August 23, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.70%, the 77th percentile. Fixed in libextractor 1:1.9-2.
References
bugs.gnunet.org/view.php?id=5846
lists.debian.org/debian-lts-announce/2019/08/msg00038.html
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/GRQUHTSNOCKGRKPRXPUJ6FGTVZ2K5POL
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MUJWNWDGGXQLTNQNELKERJ7DLW7E22BK
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DV5YBIS2UUNUUKQOEKDWUKEEWJIKWFMZ
lists.debian.org/debian-lts-announce/2021/12/msg00016.html
Show 12 moreShow less
nvd.nist.gov/vuln/detail/CVE-2019-15531
lists.fedoraproject.org/archives/list/[email protected]/message/DV5YBIS2UUNUUKQOEKDWUKEEWJIKWFMZ
lists.fedoraproject.org/archives/list/[email protected]/message/GRQUHTSNOCKGRKPRXPUJ6FGTVZ2K5POL
lists.fedoraproject.org/archives/list/[email protected]/message/MUJWNWDGGXQLTNQNELKERJ7DLW7E22BK
github.com/advisories/GHSA-m4hp-jj52-f756
security-tracker.debian.org/tracker/CVE-2019-15531
advisories.mageia.org/MGASA-2020-0015.html
bugs.mageia.org/show_bug.cgi?id=25945
lists.fedoraproject.org/archives/list/[email protected]/thread/GRQUHTSNOCKGRKPRXPUJ6FGTVZ2K5POL
ubuntu.com/security/CVE-2019-15531
git.gnunet.org/libextractor.git/commit?id=d2b032452241708bee68d02aa02092cfbfba951a
cve.org/CVERecord?id=CVE-2019-15531