CVE-2019-15608
TOCTOU Race Condition in Yarn
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.9
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
- Record
CVE-2019-15608- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-840, CWE-367
- Updated
- 2026-11-02
CVE List No score
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
- Record
CVE-2019-15608- Weakness
- CWE-840
- Updated
- 2026-11-02
EUVDEUVD-2022-1051 No score
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
- Record
EUVD-2022-1051- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hjxc-462x-x77j
5.9
TOCTOU Race Condition in Yarn
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack. This issue is fixed in 1.19.0.
- Record
GHSA-hjxc-462x-x77j- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-367
- Updated
- 2026-11-02
OSV
5.9
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
- Record
CVE-2019-15608- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-15608
5.9
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
- Record
DEBIAN-CVE-2019-15608- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVGHSA-hjxc-462x-x77j
5.9
TOCTOU Race Condition in Yarn
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack. This issue is fixed in 1.19.0.
- Record
GHSA-hjxc-462x-x77j- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-367
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-15608
5.9
The package integrity validation in yarn < 1.19.0 contains a TOCTOU vulnerability where the hash is computed before writing a package to cache. It's not computed again when reading from the cache. This may lead to a cache pollution attack.
- Record
UBUNTU-CVE-2019-15608- CVSS 3.1
- 5.9 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVCLSA-2026-1786378841 No score
TuxCare security update for yarn (5 CVEs)
TuxCare rebuilt yarn to address 5 CVEs. Fixed in 1.15.2-tuxcare.1.
- Record
CLSA-2026-1786378841- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
yarnnpm |
before 1.19.0 | 1.19.0 |
yarnTuxCare:npm |
1.15.2-tuxcare.0 up to 1.15.2-tuxcare.1, plus listed versions 1.15.2 |
1.15.2-tuxcare.1 |
node-yarnpkgDebian:12 |
before 1.19.1-1 | 1.19.1-1 |
node-yarnpkgDebian:13 |
before 1.19.1-1 | 1.19.1-1 |
node-yarnpkgDebian:14 |
before 1.19.1-1 | 1.19.1-1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-15608 is a medium vulnerability (CVSS 5.9) in Yarnpkg Yarn, published March 15, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.84%, the 79th percentile. Fixed in yarn 1.19.0.
References
hackerone.com/reports/703138
github.com/yarnpkg/yarn/commit/0474b8c66a8ea298f5e4dedc67b2de464297ad1c
github.com/yarnpkg/yarn/blob/master/CHANGELOG.md
nvd.nist.gov/vuln/detail/CVE-2019-15608
github.com/advisories/GHSA-hjxc-462x-x77j
security-tracker.debian.org/tracker/CVE-2019-15608
ubuntu.com/security/CVE-2019-15608
cve.org/CVERecord?id=CVE-2019-15608