Every CVE Search/ Get API key

CVE-2019-16108

phpBB arbitrary CSS injection

7.5 HighFix available

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.08%Up 0.7 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Record
CVE-2019-16108
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-94
Updated
2026-11-02
CVE List No score

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Record
CVE-2019-16108
Updated
2026-11-02
EUVDEUVD-2022-3186 No score

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Record
EUVD-2022-3186
Updated
2026-11-03
GitHub AdvisoriesGHSA-8hc2-hvrc-x4qr 7.5

phpBB arbitrary CSS injection

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Record
GHSA-8hc2-hvrc-x4qr
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-94
Updated
2026-11-02
OSV 7.5

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Record
CVE-2019-16108
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSVGHSA-8hc2-hvrc-x4qr 7.5

phpBB arbitrary CSS injection

phpBB 3.2.7 allows adding an arbitrary Cascading Style Sheets (CSS) token sequence to a page through BBCode.

Record
GHSA-8hc2-hvrc-x4qr
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-94
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpbb/phpbb
Packagist
3.2.7 to 3.2.7
3.2.8
phpbb/phpbb
Packagist
3.2.7 up to 3.2.8, plus listed versions
3.2.8-RC1
3.2.8

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-16108 is a high vulnerability (CVSS 7.5) in Phpbb, published March 19, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.08%, the 65th percentile. Fixed in phpbb/phpbb 3.2.8.

References

MoveEnter Open