CVE-2019-16392
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
CVE-2019-16392 is a medium vulnerability (CVSS 6.1) in Spip, published September 17, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.16%, the 67th percentile. Fixed in spip 3.2.5-1.
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
- Record
CVE-2019-16392- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
- Record
CVE-2019-16392- Updated
- 2026-11-02
EUVDEUVD-2019-7140 No score
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
- Record
EUVD-2019-7140- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6j3r-8pmv-5j3p
6.1
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
- Record
GHSA-6j3r-8pmv-5j3p- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
- Record
CVE-2019-16392- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-16392
6.1
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
- Record
DEBIAN-CVE-2019-16392- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-16392
6.1
SPIP before 3.1.11 and 3.2 before 3.2.5 allows prive/formulaires/login.php XSS via error messages.
- Record
UBUNTU-CVE-2019-16392- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUSN-4536-1 No score
spip vulnerabilities
Youssouf Boulouiz discovered that SPIP incorrectly handled login error messages. A remote attacker could potentially exploit this to conduct cross-site scripting (XSS) attacks. (CVE-2019-16392)
Gilles Vincent discovered that SPIP incorrectly handled password reset requests. A remote attacker could possibly use this issue to cause SPIP to enumerate registered users. (CVE-2019-16394)
Guillaume Fahrner discovered that SPIP did not properly sanitize input. A remote authenticated attacker could possibly use this issue to execute arbitrary code on the host server. (CVE-2019-11071)
Sylvain Lefevre discovered that SPIP incorrectly handled user authorization. A remote attacker could possibly use this issue to modify and publish content and modify the database. (CVE-2019-16391)
It was discovered that SPIP did not properly sanitize input. A remote attacker could, through cross-site scripting (XSS) and PHP injection, exploit this to inject arbitrary web script or HTML. (CVE-2017-15736)
Alexis Zucca discovered that SPIP incorrectly handled the media plugin. A remote authenticated attacker could possibly use this issue to write to the database. (CVE-2019-19830)
Christophe Laffont discovered that SPIP incorrectly handled redirect URLs. An attacker could use this issue to cause SPIP to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2019-16393)
- Record
USN-4536-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
spipDebian:13 |
before 3.2.5-1 | 3.2.5-1 |
spipDebian:14 |
before 3.2.5-1 | 3.2.5-1 |
spipDebian:8 |
before 3.0.17-2+deb8u5, plus listed versions 3.0.17-23.0.17-2+deb8u13.0.17-2+deb8u23.0.17-2+deb8u33.0.17-2+deb8u4 |
3.0.17-2+deb8u5 |
spipDebian:9 |
before 3.1.4-4~deb9u3, plus listed versions 3.1.4-23.1.4-33.1.4-3~deb9u13.1.4-4~deb9u13.1.4-4~deb9u2 |
3.1.4-4~deb9u3 |
spipDebian:10 |
before 3.2.4-1+deb10u1, plus listed versions 3.2.4-1 |
3.2.4-1+deb10u1 |
spipUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 3.0.20-13.0.21-13.0.21-1ubuntu13.0.21-1ubuntu1+esm1 |
None known |
spipUbuntu:18.04:LTS |
before 3.1.4-4~deb9u3build0.18.04.1, plus listed versions 3.1.4-3 |
3.1.4-4~deb9u3build0.18.04.1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-Sortie-de-SPIP-3-2-5-et-SPIP-3-1-11.html
git.spip.net/SPIP/spip/commit/3c12a82c7d9d4afd09e708748fa82e7836174028
seclists.org/bugtraq/2019/Sep/40
debian.org/security/2019/dsa-4532
lists.debian.org/debian-lts-announce/2019/10/msg00038.html
usn.ubuntu.com/4536-1
Show 12 moreShow less
nvd.nist.gov/vuln/detail/CVE-2019-16392
github.com/advisories/GHSA-6j3r-8pmv-5j3p
security-tracker.debian.org/tracker/CVE-2019-16392
ubuntu.com/security/CVE-2019-16392
ubuntu.com/security/notices/USN-4536-1
cve.org/CVERecord?id=CVE-2019-16392
ubuntu.com/security/CVE-2017-15736
ubuntu.com/security/CVE-2019-11071
ubuntu.com/security/CVE-2019-16391
ubuntu.com/security/CVE-2019-16393
ubuntu.com/security/CVE-2019-16394
ubuntu.com/security/CVE-2019-19830