CVE-2019-16762
Validator parsing discrepancy due to string encoding in NPM slpjs
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
5.7
Validator parsing discrepancy due to string encoding in NPM slpjs
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.
- Record
CVE-2019-16762- CVSS 3.1
- 5.7 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
EUVDEUVD-2019-0725
5.7
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.
- Record
EUVD-2019-0725- CVSS 3.1
- 5.7 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-425c-ccf3-3jrr
5.7
Critical severity vulnerability that affects slpjs
Validator parsing discrepancy due to string encoding
Impact
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus.
Patches
All versions > 0.21.3 are patched.
Workarounds
Upgrade to any version >= 0.21.4.
References
The bug was located and fixed here.
For more information
If you have any questions or comments about this advisory:
- Open an issue in the slpjs repo
- Email us at [email protected]
- Record
GHSA-425c-ccf3-3jrr- CVSS 3.1
- 5.7 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
NVD
5.7
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.
- Record
CVE-2019-16762- CVSS 3.1
- 5.7 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:H - CVSS 2.0
- 4.9 Medium
AV:N/AC:M/Au:S/C:N/I:P/A:P - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
6.1
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.
- Record
CVE-2019-16762- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:N/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-425c-ccf3-3jrr
5.7
Critical severity vulnerability that affects slpjs
Validator parsing discrepancy due to string encoding
Impact
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus.
Patches
All versions > 0.21.3 are patched.
Workarounds
Upgrade to any version >= 0.21.4.
References
The bug was located and fixed here.
For more information
If you have any questions or comments about this advisory:
- Open an issue in the slpjs repo
- Email us at [email protected]
- Record
GHSA-425c-ccf3-3jrr- CVSS 3.1
- 5.7 Medium
CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:H - Weakness
- CWE-20
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
slpjsnpm |
before 0.21.4 | 0.21.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-16762 is a medium vulnerability (CVSS 5.7) in Simpleledger Slpjs, published November 15, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.10%, the 65th percentile. Fixed in slpjs 0.21.4.