Every CVE Search/ Get API key

CVE-2019-16791

downgrade of effective Strict Transport Security (STS) policy in postfix-mta-sts-resolver

6.9 MediumFix available

In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.86%Up 0.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 6.9

downgrade of effective Strict Transport Security (STS) policy in postfix-mta-sts-resolver

In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

Record
CVE-2019-16791
CVSS 3.1
6.9 MediumCVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-757
Updated
2026-11-02
EUVDEUVD-2020-0149 6.9

In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

Record
EUVD-2020-0149
CVSS 3.1
6.9 MediumCVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-h92m-42h4-82f6 8.7

postfix-mta-sts-resolver Algorithm Downgrade vulnerability

Incorrect query parsing

Impact

All users of versions prior to 0.5.1 can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

Patches

Problem has been patched in version 0.5.1

Workarounds

Users may remediate this vulnerability without upgrading by applying these patches to older suppoorted versions.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-h92m-42h4-82f6
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
CVSS 3.1
6.9 MediumCVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-757
Updated
2026-11-02
NVD 6.9

In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

Record
CVE-2019-16791
CVSS 3.1
6.9 MediumCVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-757
Updated
2026-11-02
OSV 5.9

In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

Record
CVE-2019-16791
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-h92m-42h4-82f6 8.7

postfix-mta-sts-resolver Algorithm Downgrade vulnerability

Incorrect query parsing

Impact

All users of versions prior to 0.5.1 can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

Patches

Problem has been patched in version 0.5.1

Workarounds

Users may remediate this vulnerability without upgrading by applying these patches to older suppoorted versions.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-h92m-42h4-82f6
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
CVSS 3.1
6.9 MediumCVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
Weakness
CWE-757
Updated
2026-11-02
OSVUBUNTU-CVE-2019-16791 6.9

In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

Record
UBUNTU-CVE-2019-16791
CVSS 3.1
6.9 MediumCVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N
CVSS 3.1
5.9 MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVPYSEC-2020-174 No score

In postfix-mta-sts-resolver before 0.5.1, All users can receive incorrect response from daemon under rare conditions, rendering downgrade of effective STS policy.

Record
PYSEC-2020-174
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
postfix-mta-sts-resolver
PyPI
before 0.5.1
0.5.1
postfix-mta-sts-resolver
PyPI
before 0.5.1, plus listed versions
0.1.10.1.20.1.30.1.40.1.5
Show 17 moreShow less
0.2.00.2.10.2.20.2.30.2.40.2.50.2.70.2.80.2.90.3.00.4.00.4.10.4.20.4.30.4.40.4.50.5.0
0.5.1
postfix-mta-sts-resolver
Ubuntu:20.04:LTS
All versions, plus listed versions
0.6.0-10.7.0-10.7.3-10.7.5-1
None known
postfix-mta-sts-resolver
Ubuntu:22.04:LTS
All versions, plus listed versions
1.0.0-41.1.2-1
None known
postfix-mta-sts-resolver
Ubuntu:24.04:LTS
All versions, plus listed versions
1.1.2-1.11.1.2-1.1ubuntu0.1
None known
postfix-mta-sts-resolver
Ubuntu:25.10
All versions, plus listed versions
1.5.0-1
None known
postfix-mta-sts-resolver
Ubuntu:26.10
All versions, plus listed versions
1.5.0-1build11.5.1-1
None known
postfix-mta-sts-resolver
Ubuntu:26.04:LTS
All versions, plus listed versions
1.5.0-11.5.0-1build1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-16791 is a medium vulnerability (CVSS 6.9) in Postfix-mta-sts-resolver Project Postfix-mta-sts-resolver, published July 5, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.86%, the 58th percentile. Fixed in postfix-mta-sts-resolver 0.5.1.

References

MoveEnter Open