CVE-2019-17109
koji hub allows arbitrary upload destinations
Koji through 1.18.0 allows remote Directory Traversal, with resultant Privilege Escalation.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
Koji through 1.18.0 allows remote Directory Traversal, with resultant Privilege Escalation.
- Record
CVE-2019-17109- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List No score
Koji through 1.18.0 allows remote Directory Traversal, with resultant Privilege Escalation.
- Record
CVE-2019-17109- Updated
- 2026-11-02
EUVDEUVD-2019-0073 No score
Koji through 1.18.0 allows remote Directory Traversal, with resultant Privilege Escalation.
- Record
EUVD-2019-0073- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-7498-c9fm-g64p
7.1
koji hub allows arbitrary upload destinations
The way that the hub code validates upload paths allows for an attacker to choose an arbitrary destination for the uploaded file. Uploading still requires login. However, an attacker with credentials could damage the integrity of the Koji system.
Workaround
There is no known workaround. All Koji admins are encouraged to update to a fixed version as soon as possible.
Fix
Koji versions 1.14.3, 1.15.3, 1.16.3, 1.17.1, and 1.18.1 all include patches to solve this vulnerability.
- Record
GHSA-7498-c9fm-g64p- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVGHSA-7498-c9fm-g64p
7.1
koji hub allows arbitrary upload destinations
The way that the hub code validates upload paths allows for an attacker to choose an arbitrary destination for the uploaded file. Uploading still requires login. However, an attacker with credentials could damage the integrity of the Koji system.
Workaround
There is no known workaround. All Koji admins are encouraged to update to a fixed version as soon as possible.
Fix
Koji versions 1.14.3, 1.15.3, 1.16.3, 1.17.1, and 1.18.1 all include patches to solve this vulnerability.
- Record
GHSA-7498-c9fm-g64p- CVSS 4.0
- 7.1 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-17109
6.5
Koji through 1.18.0 allows remote Directory Traversal, with resultant Privilege Escalation.
- Record
UBUNTU-CVE-2019-17109- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVMGASA-2021-0147 No score
Updated koji packages fix security vulnerability
Koji through 1.17.0 allows remote Directory Traversal, with resulting Privilege Escalation.
- Record
MGASA-2021-0147- Updated
- 2026-11-02
OSVPYSEC-2019-183 No score
Koji through 1.18.0 allows remote Directory Traversal, with resultant Privilege Escalation.
- Record
PYSEC-2019-183- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
kojiPyPI |
1.14.0 up to 1.14.3 | 1.14.3 |
kojiPyPI |
1.15.0 up to 1.15.3 | 1.15.3 |
kojiPyPI |
1.16.0 up to 1.16.3 | 1.16.3 |
kojiPyPI |
1.17.0 up to 1.17.1 | 1.17.1 |
kojiPyPI |
1.18.0 up to 1.18.1 | 1.18.1 |
kojiPyPI |
1.16.0 up to 1.16.3, plus listed versions 1.16.1 |
1.16.3 |
kojiMageia:7 |
before 1.17.1-1.mga7 | 1.17.1-1.mga7 |
kojiPyPI |
before 1.19.0, plus listed versions 1.15.01.16.01.16.11.17.01.18.0 |
1.19.0 |
kojiUbuntu:16.04:LTS |
All versions, plus listed versions 1.10.0-1 |
None known |
kojiUbuntu:18.04:LTS |
All versions, plus listed versions 1.10.0-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-17109 is a medium vulnerability (CVSS 6.5) in Koji Project Koji, published October 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.21%, the 88th percentile. Fixed in koji 1.14.3.
References
openwall.com/lists/oss-security/2019/10/09/5
docs.pagure.org/koji/CVE-2019-17109
pagure.io/koji/commits/master
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/7PSCCFHLNVFLDPC7DB4UJGXD6ZWBSY57
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/4BGUXMZIAQFFNNQ7PEFDAYQCXXKJR76U
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/DEQYYGWLJBQQVTAC7E7XSDGVF27NPMPB
Show 16 moreShow less
nvd.nist.gov/vuln/detail/CVE-2019-17109
github.com/koji-project/koji/commit/91d6f0b607c7f5af666dfb56931f1db4e38c28a5
github.com/koji-project/koji/blob/d0507c4d2d2269daa984db642e3bd957dff18948/docs/source/CVEs/CVE-2019-17109.rst
pagure.io/koji/issue/1634
pagure.io/koji/pull-request/1686
github.com/pypa/advisory-database/tree/main/vulns/koji/PYSEC-2019-183.yaml
lists.fedoraproject.org/archives/list/[email protected]/message/4BGUXMZIAQFFNNQ7PEFDAYQCXXKJR76U
lists.fedoraproject.org/archives/list/[email protected]/message/7PSCCFHLNVFLDPC7DB4UJGXD6ZWBSY57
lists.fedoraproject.org/archives/list/[email protected]/message/DEQYYGWLJBQQVTAC7E7XSDGVF27NPMPB
github.com/advisories/GHSA-7498-c9fm-g64p
github.com/koji-project/koji
advisories.mageia.org/MGASA-2021-0147.html
bugs.mageia.org/show_bug.cgi?id=25959
bugzilla.redhat.com/show_bug.cgi?id=1768882
ubuntu.com/security/CVE-2019-17109
cve.org/CVERecord?id=CVE-2019-17109