Every CVE Search/ Get API key

CVE-2019-17113

In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName...

9.8 CriticalFix available

In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.75%Up 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.

Record
CVE-2019-17113
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-120
Updated
2026-11-02
CVE List No score

In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.

Record
CVE-2019-17113
Updated
2026-11-02
EUVDEUVD-2019-7574 No score

In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.

Record
EUVD-2019-7574
Updated
2026-11-03
GitHub AdvisoriesGHSA-9qmp-r7mf-m39c No score

In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName...

In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.

Record
GHSA-9qmp-r7mf-m39c
Updated
2026-11-02
OSV 9.8

In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.

Record
CVE-2019-17113
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-17113 9.8

In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.

Record
DEBIAN-CVE-2019-17113
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVUBUNTU-CVE-2019-17113 9.8

In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.

Record
UBUNTU-CVE-2019-17113
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2019:2306-1 No score

Security update for libopenmpt

This update for libopenmpt to version 0.3.19 fixes the following issues:

  • CVE-2019-17113: Fixed a buffer overflow in ModPlug_InstrumentName and ModPlug_SampleName (bsc#1153102).

This update was imported from the SUSE:SLE-15:Update update project.

Record
openSUSE-SU-2019:2306-1
Updated
2026-11-02
OSVopenSUSE-SU-2019:2319-1 No score

Security update for libopenmpt

This update for libopenmpt to version 0.3.19 fixes the following issues:

  • CVE-2019-17113: Fixed a buffer overflow in ModPlug_InstrumentName and ModPlug_SampleName (bsc#1153102).

This update was imported from the SUSE:SLE-15:Update update project.

Record
openSUSE-SU-2019:2319-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:10965-1 No score

libopenmpt-devel-0.5.11-1.2 on GA media

These are all security issues fixed in the libopenmpt-devel-0.5.11-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:10965-1
Updated
2026-11-02
OSVSUSE-SU-2019:2622-1 No score

Security update for libopenmpt

This update for libopenmpt to version 0.3.19 fixes the following issues:

  • CVE-2019-17113: Fixed a buffer overflow in ModPlug_InstrumentName and ModPlug_SampleName (bsc#1153102).
Record
SUSE-SU-2019:2622-1
Updated
2026-11-02
OSVUSN-8206-1 No score

libopenmpt vulnerability

Antonio Morales Maldonado discovered that OpenMPT did not properly limit the length of strings in certain cases, leading to a buffer overflow. An attacker could possibly use this issue to cause OpenMPT to crash, resulting in a denial of service.

Record
USN-8206-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libopenmpt
Debian:12
before 0.4.9-1
0.4.9-1
libopenmpt
Debian:13
before 0.4.9-1
0.4.9-1
libopenmpt
Debian:14
before 0.4.9-1
0.4.9-1
libopenmpt
Debian:9
before 0.2.7386~beta20.3-3+deb9u4, plus listed versions
0.2.7386~beta20.3-30.2.7386~beta20.3-3+deb9u10.2.7386~beta20.3-3+deb9u20.2.7386~beta20.3-3+deb9u3
0.2.7386~beta20.3-3+deb9u4
libopenmpt
Debian:10
From an advisory covering 2 CVEs
before 0.4.3-1+deb10u1, plus listed versions
0.4.3-1
0.4.3-1+deb10u1
libopenmpt
SUSE:Linux Enterprise Module for Desktop Applications 15
before 0.3.19-2.10.1
0.3.19-2.10.1
libopenmpt
SUSE:Linux Enterprise Module for Desktop Applications 15 SP1
before 0.3.19-2.10.1
0.3.19-2.10.1
libopenmpt
Ubuntu:Pro:18.04:LTS
before 0.3.6-1ubuntu0.1~esm2, plus listed versions
0.2.8760~beta27-10.3.1-10.3.2-10.3.3-10.3.4-10.3.6-10.3.6-1ubuntu0.1~esm1
0.3.6-1ubuntu0.1~esm2
libopenmpt
openSUSE:Leap 15.1
before 0.3.19-lp151.2.6.1
0.3.19-lp151.2.6.1
libopenmpt
openSUSE:Leap 15.0
before 0.3.19-lp150.10.1
0.3.19-lp150.10.1

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-17113 is a critical vulnerability (CVSS 9.8) in Openmpt Libopenmpt, published October 3, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.75%, the 86th percentile. Fixed in libopenmpt 0.4.9-1.

References

Show 20 moreShow less
MoveEnter Open