Every CVE Search/ Get API key

CVE-2019-17266

libsoup through 2.68.1 has a heap-based buffer over-read because soup_ntlm_parse_challenge() in...

9.8 CriticalFix available

libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.78%Up 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.

Record
CVE-2019-17266
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.

Record
CVE-2019-17266
Updated
2026-11-02
EUVDEUVD-2019-7681 No score

libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.

Record
EUVD-2019-7681
Updated
2026-11-03
GitHub AdvisoriesGHSA-wcxh-xxc8-v5j8 9.8

libsoup through 2.68.1 has a heap-based buffer over-read because soup_ntlm_parse_challenge() in...

libsoup through 2.68.1 has a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.

Record
GHSA-wcxh-xxc8-v5j8
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVALPINE-CVE-2019-17266 9.8

libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.

Record
ALPINE-CVE-2019-17266
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 9.8

libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.

Record
CVE-2019-17266
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVDEBIAN-CVE-2019-17266 9.8

libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.

Record
DEBIAN-CVE-2019-17266
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-17266 9.8

libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.

Record
UBUNTU-CVE-2019-17266
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0312 No score

Updated libsoup packages fix security vulnerability

Updated libsoup package fixes security vulnerability:

It was discovered that libsoup incorrectly handled parsing certain NTLM messages. If a user or automated system were tricked into connecting to a malicious server, a remote attacker could possibly use this issue to cause a denial of service (CVE-2019-17266).

Record
MGASA-2019-0312
Updated
2026-11-02
OSVUSN-4152-1 No score

libsoup2.4 vulnerability

It was discovered that libsoup incorrectly handled parsing certain NTLM messages. If a user or automated system were tricked into connecting to a malicious server, a remote attacker could possibly use this issue to cause a denial of service.

Record
USN-4152-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libsoup
Alpine:v3.10
2.65.1 up to 2.66.2-r2
2.66.2-r2
libsoup
Alpine:v3.11
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.12
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.13
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.14
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.15
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.16
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.17
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.18
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.19
2.65.1 up to 2.68.2-r0
2.68.2-r0
Show 8 moreShow less
Affected packages
PackageAffectedFixed
libsoup
Alpine:v3.20
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.21
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.22
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup
Alpine:v3.23
2.65.1 up to 2.68.2-r0
2.68.2-r0
libsoup2.4
Debian:12
before 2.68.2-1
2.68.2-1
libsoup2.4
Debian:13
before 2.68.2-1
2.68.2-1
libsoup
Mageia:7
before 2.66.1-2.1.mga7
2.66.1-2.1.mga7
libsoup2.4
Ubuntu:18.04:LTS
before 2.62.1-1ubuntu0.4, plus listed versions
2.60.1-12.60.2-12.60.2-22.60.3-12.61.90-1
Show 4 moreShow less
2.62.0-12.62.1-12.62.1-1ubuntu0.12.62.1-1ubuntu0.3
2.62.1-1ubuntu0.4

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-17266 is a critical vulnerability (CVSS 9.8) in Gnome Libsoup, published October 6, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.78%, the 86th percentile. Fixed in libsoup 2.66.2-r2.

References

Show 10 moreShow less
MoveEnter Open