CVE-2019-17670
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows...
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
- Record
CVE-2019-17670- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-918
- Updated
- 2026-11-02
CVE List No score
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
- Record
CVE-2019-17670- Updated
- 2026-11-02
EUVDEUVD-2019-7975 No score
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
- Record
EUVD-2019-7975- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-9vwr-ww7h-qvv8
9.8
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows...
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
- Record
GHSA-9vwr-ww7h-qvv8- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918
- Updated
- 2026-11-02
OSV
9.8
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
- Record
CVE-2019-17670- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-17670
9.8
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
- Record
DEBIAN-CVE-2019-17670- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-17670
9.8
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
- Record
UBUNTU-CVE-2019-17670- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressDebian:12 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:13 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:14 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:8 From an advisory covering 4 CVEs |
before 4.1.28+dfsg-0+deb8u1, plus listed versions 4.1+dfsg-14.1+dfsg-1+deb8u14.1+dfsg-1+deb8u104.1+dfsg-1+deb8u114.1+dfsg-1+deb8u12 Show 18 moreShow less4.1+dfsg-1+deb8u134.1+dfsg-1+deb8u144.1+dfsg-1+deb8u154.1+dfsg-1+deb8u164.1+dfsg-1+deb8u174.1+dfsg-1+deb8u184.1+dfsg-1+deb8u24.1+dfsg-1+deb8u34.1+dfsg-1+deb8u44.1+dfsg-1+deb8u54.1+dfsg-1+deb8u64.1+dfsg-1+deb8u74.1+dfsg-1+deb8u84.1+dfsg-1+deb8u94.1.1+dfsg-14.1.25+dfsg-1+deb8u14.1.26+dfsg-1+deb8u14.1.27+dfsg-0+deb8u1 |
4.1.28+dfsg-0+deb8u1 |
wordpressDebian:9 From an advisory covering 6 CVEs |
before 4.7.18+dfsg-1+deb9u1, plus listed versions 4.7.5+dfsg-24.7.5+dfsg-2+deb9u14.7.5+dfsg-2+deb9u1~bpo8+14.7.5+dfsg-2+deb9u24.7.5+dfsg-2+deb9u2~bpo8+1 Show 4 moreShow less4.7.5+dfsg-2+deb9u34.7.5+dfsg-2+deb9u44.7.5+dfsg-2+deb9u54.7.5+dfsg-2+deb9u6 |
4.7.18+dfsg-1+deb9u1 |
wordpressDebian:10 |
before 5.0.17+dfsg1-0+deb10u1, plus listed versions 5.0.10+dfsg1-0+deb10u15.0.11+dfsg1-0+deb10u15.0.12+dfsg1-0+deb10u15.0.14+dfsg1-0+deb10u15.0.15+dfsg1-0+deb10u15.0.4+dfsg1-15.0.4+dfsg1-1+deb10u15.0.4+dfsg1-1+deb10u2 |
5.0.17+dfsg1-0+deb10u1 |
wordpressUbuntu:16.04:LTS |
All versions, plus listed versions 4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1 |
None known |
wordpressUbuntu:18.04:LTS |
All versions, plus listed versions 4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-17670 is a critical vulnerability (CVSS 9.8) in Wordpress, published October 17, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 4.51%, the 91st percentile. Fixed in wordpress 5.2.4+dfsg1-1.
References
blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
wordpress.org/news/2019/10/wordpress-5-2-4-security-release
core.trac.wordpress.org/changeset/46472
github.com/WordPress/WordPress/commit/9db44754b9e4044690a6c32fd74b9d5fe26b07b2
wpvulndb.com/vulnerabilities/9912
lists.debian.org/debian-lts-announce/2019/11/msg00000.html
Show 7 moreShow less
lists.debian.org/debian-lts-announce/2020/09/msg00011.html
lists.debian.org/debian-lts-announce/2022/10/msg00010.html
nvd.nist.gov/vuln/detail/CVE-2019-17670
github.com/advisories/GHSA-9vwr-ww7h-qvv8
security-tracker.debian.org/tracker/CVE-2019-17670
ubuntu.com/security/CVE-2019-17670
cve.org/CVERecord?id=CVE-2019-17670