CVE-2019-17673
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because...
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
- Record
CVE-2019-17673- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
- Record
CVE-2019-17673- Updated
- 2026-11-02
EUVDEUVD-2019-7978 No score
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
- Record
EUVD-2019-7978- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-93gm-xcwj-q3j2
7.5
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because...
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
- Record
GHSA-93gm-xcwj-q3j2- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
7.5
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
- Record
CVE-2019-17673- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-17673
7.5
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
- Record
DEBIAN-CVE-2019-17673- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-17673
7.5
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
- Record
UBUNTU-CVE-2019-17673- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressDebian:12 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:13 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:14 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:10 From an advisory covering 18 CVEs |
before 5.0.4+dfsg1-1+deb10u1, plus listed versions 5.0.4+dfsg1-1 |
5.0.4+dfsg1-1+deb10u1 |
wordpressUbuntu:16.04:LTS |
All versions, plus listed versions 4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1 |
None known |
wordpressUbuntu:18.04:LTS |
All versions, plus listed versions 4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-17673 is a high vulnerability (CVSS 7.5) in Wordpress, published October 17, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.53%, the 89th percentile. Fixed in wordpress 5.2.4+dfsg1-1.
References
wpvulndb.com/vulnerabilities/9911
blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
wordpress.org/news/2019/10/wordpress-5-2-4-security-release
core.trac.wordpress.org/changeset/46478
github.com/WordPress/WordPress/commit/b224c251adfa16a5f84074a3c0886270c9df38de
seclists.org/bugtraq/2020/Jan/8