CVE-2019-17674
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
- Record
CVE-2019-17674- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
- Record
CVE-2019-17674- Updated
- 2026-11-02
EUVDEUVD-2019-7979 No score
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
- Record
EUVD-2019-7979- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v3h4-mqmp-768j
5.4
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
- Record
GHSA-v3h4-mqmp-768j- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
- Record
CVE-2019-17674- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-17674
5.4
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
- Record
DEBIAN-CVE-2019-17674- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-17674
5.4
WordPress before 5.2.4 is vulnerable to stored XSS (cross-site scripting) via the Customizer.
- Record
UBUNTU-CVE-2019-17674- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
wordpressDebian:12 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:13 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:14 |
before 5.2.4+dfsg1-1 | 5.2.4+dfsg1-1 |
wordpressDebian:10 From an advisory covering 18 CVEs |
before 5.0.4+dfsg1-1+deb10u1, plus listed versions 5.0.4+dfsg1-1 |
5.0.4+dfsg1-1+deb10u1 |
wordpressUbuntu:16.04:LTS |
All versions, plus listed versions 4.3+dfsg-14.3.1+dfsg-14.4+dfsg-14.4.1+dfsg-14.4.2+dfsg-14.4.2+dfsg-1ubuntu1 |
None known |
wordpressUbuntu:18.04:LTS |
All versions, plus listed versions 4.8.2+dfsg-24.8.3+dfsg-14.9.1+dfsg-14.9.2+dfsg-14.9.4+dfsg-14.9.5+dfsg1-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-17674 is a medium vulnerability (CVSS 5.4) in Wordpress, published October 17, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.59%, the 75th percentile. Fixed in wordpress 5.2.4+dfsg1-1.