CVE-2019-18601
OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data...
OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data access because remote attackers can make a series of VOTE_Debug RPC calls to crash a database server within the SVOTE_Debug RPC handler.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- None
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data access because remote attackers can make a series of VOTE_Debug RPC calls to crash a database server within the SVOTE_Debug RPC handler.
- Record
CVE-2019-18601- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:N/A:P - Weakness
- CWE-502
- Updated
- 2026-11-02
CVE List No score
OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data access because remote attackers can make a series of VOTE_Debug RPC calls to crash a database server within the SVOTE_Debug RPC handler.
- Record
CVE-2019-18601- Updated
- 2026-11-02
EUVDEUVD-2019-8335 No score
OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data access because remote attackers can make a series of VOTE_Debug RPC calls to crash a database server within the SVOTE_Debug RPC handler.
- Record
EUVD-2019-8335- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m28x-w8m6-pc3f
7.5
OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data...
OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data access because remote attackers can make a series of VOTE_Debug RPC calls to crash a database server within the SVOTE_Debug RPC handler.
- Record
GHSA-m28x-w8m6-pc3f- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-502
- Updated
- 2026-11-02
OSV
7.5
OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data access because remote attackers can make a series of VOTE_Debug RPC calls to crash a database server within the SVOTE_Debug RPC handler.
- Record
CVE-2019-18601- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-18601
7.5
OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data access because remote attackers can make a series of VOTE_Debug RPC calls to crash a database server within the SVOTE_Debug RPC handler.
- Record
DEBIAN-CVE-2019-18601- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-18601
7.5
OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to denial of service from unserialized data access because remote attackers can make a series of VOTE_Debug RPC calls to crash a database server within the SVOTE_Debug RPC handler.
- Record
UBUNTU-CVE-2019-18601- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openafsDebian:12 |
before 1.8.5-1 | 1.8.5-1 |
openafsDebian:13 |
before 1.8.5-1 | 1.8.5-1 |
openafsDebian:8 From an advisory covering 3 CVEs |
before 1.6.9-2+deb8u9, plus listed versions 1.6.9-2+deb8u21.6.9-2+deb8u31.6.9-2+deb8u41.6.9-2+deb8u4~bpo70+11.6.9-2+deb8u51.6.9-2+deb8u61.6.9-2+deb8u71.6.9-2+deb8u8 |
1.6.9-2+deb8u9 |
openafsUbuntu:16.04:LTS |
All versions, plus listed versions 1.6.14-11.6.15-11.6.15-1ubuntu11.6.15-1ubuntu1.1 |
None known |
openafsUbuntu:18.04:LTS |
All versions, plus listed versions 1.6.21-31.6.21-3ubuntu11.6.22-31.8.0~pre4-11.8.0~pre5-11.8.0~pre5-1ubuntu11.8.0~pre5-1ubuntu1.11.8.0~pre5-1ubuntu1.2 |
None known |
openafsUbuntu:20.04:LTS |
All versions, plus listed versions 1.8.4~pre1-1ubuntu21.8.4~pre1-1ubuntu2.11.8.4~pre1-1ubuntu2.21.8.4~pre1-1ubuntu2.31.8.4~pre1-1ubuntu2.4 |
None known |
openafsUbuntu:22.04:LTS |
All versions, plus listed versions 1.8.6-5ubuntu21.8.8-31.8.8.1-11.8.8.1-3ubuntu2~22.04.11.8.8.1-3ubuntu2~22.04.21.8.10-2ubuntu1~22.04.11.8.10-2ubuntu1~22.04.2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-18601 is a high vulnerability (CVSS 7.5) in Openafs, published October 29, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.40%, the 72nd percentile. Fixed in openafs 1.8.5-1.
References
openafs.org/pages/security/OPENAFS-SA-2019-003.txt
lists.debian.org/debian-lts-announce/2019/11/msg00002.html
nvd.nist.gov/vuln/detail/CVE-2019-18601
github.com/advisories/GHSA-m28x-w8m6-pc3f
security-tracker.debian.org/tracker/CVE-2019-18601
ubuntu.com/security/CVE-2019-18601
cve.org/CVERecord?id=CVE-2019-18601