Every CVE Search/ Get API key

CVE-2019-18602

OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability...

7.5 HighFix available

OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability because uninitialized scalars are sent over the network to a peer.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

1.53%Up 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability because uninitialized scalars are sent over the network to a peer.

Record
CVE-2019-18602
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-908
Updated
2026-11-02
CVE List No score

OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability because uninitialized scalars are sent over the network to a peer.

Record
CVE-2019-18602
Updated
2026-11-02
EUVDEUVD-2019-8336 No score

OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability because uninitialized scalars are sent over the network to a peer.

Record
EUVD-2019-8336
Updated
2026-11-03
GitHub AdvisoriesGHSA-hr87-jrrm-jr77 No score

OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability...

OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability because uninitialized scalars are sent over the network to a peer.

Record
GHSA-hr87-jrrm-jr77
Weakness
CWE-200, CWE-908
Updated
2026-11-02
OSV 7.5

OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability because uninitialized scalars are sent over the network to a peer.

Record
CVE-2019-18602
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2019-18602 7.5

OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability because uninitialized scalars are sent over the network to a peer.

Record
DEBIAN-CVE-2019-18602
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2019-18602 7.5

OpenAFS before 1.6.24 and 1.8.x before 1.8.5 is prone to an information disclosure vulnerability because uninitialized scalars are sent over the network to a peer.

Record
UBUNTU-CVE-2019-18602
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
openafs
Debian:12
before 1.8.5-1
1.8.5-1
openafs
Debian:13
before 1.8.5-1
1.8.5-1
openafs
Debian:8
From an advisory covering 3 CVEs
before 1.6.9-2+deb8u9, plus listed versions
1.6.9-2+deb8u21.6.9-2+deb8u31.6.9-2+deb8u41.6.9-2+deb8u4~bpo70+11.6.9-2+deb8u51.6.9-2+deb8u61.6.9-2+deb8u71.6.9-2+deb8u8
1.6.9-2+deb8u9
openafs
Ubuntu:16.04:LTS
All versions, plus listed versions
1.6.14-11.6.15-11.6.15-1ubuntu11.6.15-1ubuntu1.1
None known
openafs
Ubuntu:18.04:LTS
All versions, plus listed versions
1.6.21-31.6.21-3ubuntu11.6.22-31.8.0~pre4-11.8.0~pre5-11.8.0~pre5-1ubuntu11.8.0~pre5-1ubuntu1.11.8.0~pre5-1ubuntu1.2
None known
openafs
Ubuntu:20.04:LTS
All versions, plus listed versions
1.8.4~pre1-1ubuntu21.8.4~pre1-1ubuntu2.11.8.4~pre1-1ubuntu2.21.8.4~pre1-1ubuntu2.31.8.4~pre1-1ubuntu2.4
None known
openafs
Ubuntu:22.04:LTS
All versions, plus listed versions
1.8.6-5ubuntu21.8.8-31.8.8.1-11.8.8.1-3ubuntu2~22.04.11.8.8.1-3ubuntu2~22.04.21.8.10-2ubuntu1~22.04.11.8.10-2ubuntu1~22.04.2
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-18602 is a high vulnerability (CVSS 7.5) in Openafs, published October 29, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.53%, the 74th percentile. Fixed in openafs 1.8.5-1.

References

MoveEnter Open