Every CVE Search/ Get API key

CVE-2019-18622

SQL injection in phpMyAdmin

9.8 CriticalFix available

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.24%Up 0.8 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Record
CVE-2019-18622
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-89
Updated
2026-11-02
CVE List No score

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Record
CVE-2019-18622
Updated
2026-11-02
EUVDEUVD-2020-0268 No score

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Record
EUVD-2020-0268
Updated
2026-11-03
GitHub AdvisoriesGHSA-jgjc-332c-8cmc 9.8

SQL injection in phpMyAdmin

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Record
GHSA-jgjc-332c-8cmc
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
OSVALPINE-CVE-2019-18622 9.8

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Record
ALPINE-CVE-2019-18622
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 9.8

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Record
CVE-2019-18622
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2019-18622 9.8

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Record
DEBIAN-CVE-2019-18622
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-jgjc-332c-8cmc 9.8

SQL injection in phpMyAdmin

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.

Record
GHSA-jgjc-332c-8cmc
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
OSVMGASA-2019-0357 No score

Updated phpmyadmin packages fix security vulnerability

An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/ table name can be used to trigger a SQL injection attack through the designer feature (CVE-2019-18622).

Record
MGASA-2019-0357
Updated
2026-11-02
OSVopenSUSE-SU-2019:2599-1 No score

Security update for phpMyAdmin

This update for phpMyAdmin fixes the following issues:

phpMyAdmin was updated to 4.9.2:

  • CVE-2019-18622: SQL injection in Designer feature (boo#1157614)
  • Fixes for 'Failed to set session cookie' error
  • Advisor with MySQL 8.0.3 and newer
  • Fix PHP deprecation errors
  • Fix a situation where exporting users after a delete query could remove users
  • Fix incorrect 'You do not have privileges to manipulate with the users!' warning
  • Fix copying a database's privileges and several other problems moving columns with MariaDB
  • Fix for phpMyAdmin not selecting all the values when using shift-click to select during Export
Record
openSUSE-SU-2019:2599-1
Updated
2026-11-02
OSVopenSUSE-SU-2020:0056-1 No score

Security update for phpMyAdmin

This update for phpMyAdmin to version 4.9.4 fixes the following issues:

  • CVE-2020-5504: SQL injection in user accounts page (boo#1160456).
Record
openSUSE-SU-2020:0056-1
Updated
2026-11-02
OSVopenSUSE-SU-2024:11171-1 No score

phpMyAdmin-5.1.1-1.2 on GA media

These are all security issues fixed in the phpMyAdmin-5.1.1-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11171-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
phpmyadmin/phpmyadmin
Packagist
before 4.9.2
4.9.2
phpmyadmin
Alpine:v3.11
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.12
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.13
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.14
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.15
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.16
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.17
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.18
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.19
before 4.9.2-r0
4.9.2-r0
Show 20 moreShow less
Affected packages
PackageAffectedFixed
phpmyadmin
Alpine:v3.20
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.21
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.22
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.23
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Alpine:v3.24
before 4.9.2-r0
4.9.2-r0
phpmyadmin
Debian:12
before 4:4.9.2+dfsg1-1
4:4.9.2+dfsg1-1
phpmyadmin
Debian:13
before 4:4.9.2+dfsg1-1
4:4.9.2+dfsg1-1
phpmyadmin
Debian:14
before 4:4.9.2+dfsg1-1
4:4.9.2+dfsg1-1
phpmyadmin/phpmyadmin
Packagist
before 4.9.2, plus listed versions
4.0.04.0.14.0.104.0.10.14.0.10.2
Show 37 moreShow less
4.0.10.34.0.10.44.0.10.54.0.10.64.0.10.74.0.10.84.0.10.94.0.24.0.34.0.44.0.4.14.0.4.24.0.54.0.64.0.74.0.84.0.94.7.04.7.14.7.24.7.34.7.44.7.54.7.64.7.74.7.84.7.94.8.04.8.0.14.8.14.8.24.8.34.8.44.8.54.9.04.9.0.14.9.1
4.9.2
phpmyadmin
Mageia:7
before 4.9.2-1.mga7
4.9.2-1.mga7
phpMyAdmin
SUSE:Package Hub 12
before 4.9.2-bp151.3.9.1
4.9.2-bp151.3.9.1
phpMyAdmin
SUSE:Package Hub 15
before 4.9.2-bp151.3.9.1
4.9.2-bp151.3.9.1
phpMyAdmin
SUSE:Package Hub 15 SP1
before 4.9.2-bp151.3.9.1
4.9.2-bp151.3.9.1
phpMyAdmin
openSUSE:Leap 15.0
before 4.9.2-bp151.3.9.1
4.9.2-bp151.3.9.1
phpMyAdmin
openSUSE:Leap 15.1
before 4.9.2-bp151.3.9.1
4.9.2-bp151.3.9.1
phpMyAdmin
SUSE:Package Hub 12
From an advisory covering 3 CVEs
before 4.9.4-bp151.3.12.1
4.9.4-bp151.3.12.1
phpMyAdmin
SUSE:Package Hub 15
From an advisory covering 3 CVEs
before 4.9.4-bp151.3.12.1
4.9.4-bp151.3.12.1
phpMyAdmin
SUSE:Package Hub 15 SP1
From an advisory covering 3 CVEs
before 4.9.4-bp151.3.12.1
4.9.4-bp151.3.12.1
phpMyAdmin
openSUSE:Leap 15.1
From an advisory covering 3 CVEs
before 4.9.4-bp151.3.12.1
4.9.4-bp151.3.12.1
phpMyAdmin
openSUSE:Tumbleweed
From an advisory covering 31 CVEs
before 5.1.1-1.2
5.1.1-1.2

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-18622 is a critical vulnerability (CVSS 9.8) in Phpmyadmin, published November 22, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.24%, the 82nd percentile. Fixed in phpmyadmin/phpmyadmin 4.9.2.

References

Show 45 moreShow less
MoveEnter Open