CVE-2019-18835
Improper Verification of Cryptographic Signature in matrix-synapse
CVE-2019-18835 is a critical vulnerability (CVSS 9.8) in Matrix Synapse, published November 7, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.86%, the 58th percentile. Fixed in matrix-synapse 1.5.0.
Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
- Record
CVE-2019-18835- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-345
- Updated
- 2026-11-02
CVE List No score
Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
- Record
CVE-2019-18835- Updated
- 2026-11-02
EUVDEUVD-2019-0083 No score
Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
- Record
EUVD-2019-0083- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-cppw-2mf8-qpm5
8.8
Improper Verification of Cryptographic Signature in matrix-synapse
Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
- Record
GHSA-cppw-2mf8-qpm5- CVSS 4.0
- 8.8 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - Weakness
- CWE-347
- Updated
- 2026-11-02
OSV
9.8
Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
- Record
CVE-2019-18835- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-18835
9.8
Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
- Record
DEBIAN-CVE-2019-18835- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 4 moreShow less
OSVGHSA-cppw-2mf8-qpm5
8.8
Improper Verification of Cryptographic Signature in matrix-synapse
Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
- Record
GHSA-cppw-2mf8-qpm5- CVSS 4.0
- 8.8 High
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:L/SC:N/SI:N/SA:N - CVSS 3.1
- 8.6 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L - Weakness
- CWE-347
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-18835
9.8
Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
- Record
UBUNTU-CVE-2019-18835- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVPYSEC-2019-186 No score
Matrix Synapse before 1.5.0 mishandles signature checking on some federation APIs. Events sent over /send_join, /send_leave, and /invite may not be correctly signed, or may not come from the expected servers.
- Record
PYSEC-2019-186- Updated
- 2026-11-02
OSVUSN-6076-1 No score
matrix-synapse vulnerabilities
It was discovered that Synapse incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to cause a denial of service. (CVE-2019-18835, CVE-2018-12291, CVE-2018-10657)
It was discovered that Synapse incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to hijack the session. (CVE-2019-11842, CVE-2018-12423)
It was discovered that Synapse incorrectly handled certain inputs. If a user or an automated system were tricked into opening a specially crafted input file, a remote attacker could possibly use this issue to perform spoofing or user impersonation. (CVE-2019-5885, CVE-2018-16515)
- Record
USN-6076-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
matrix-synapsePyPI |
before 1.5.0 | 1.5.0 |
matrix-synapsePyPI |
before 1.5.0, plus listed versions 0.33.50.33.5.10.33.60.33.6rc10.33.7 Show 45 moreShow less0.33.7rc10.33.7rc20.33.80.33.8rc20.33.90.34.00.34.0.10.34.0rc10.34.0rc20.34.1.10.99.00.99.0rc10.99.0rc20.99.0rc30.99.0rc40.99.10.99.1.10.99.1rc10.99.1rc20.99.20.99.2rc10.99.30.99.3.10.99.3.20.99.3rc10.99.40.99.4rc10.99.50.99.5.10.99.5.20.99.5rc11.0.01.0.0rc11.0.0rc21.0.0rc31.1.01.1.0rc11.1.0rc21.2.01.2.0rc11.2.0rc21.2.11.3.01.3.0rc11.3.1 |
1.5.0 |
matrix-synapseUbuntu:Pro:18.04:LTS |
before 0.24.0+dfsg-1ubuntu0.1~esm1, plus listed versions 0.19.2+dfsg-60.24.0+dfsg-1 |
0.24.0+dfsg-1ubuntu0.1~esm1 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | affected | |
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
github.com/matrix-org/synapse/pull/6262
github.com/matrix-org/synapse/releases/tag/v1.5.0
nvd.nist.gov/vuln/detail/CVE-2019-18835
github.com/matrix-org/synapse/commit/172f264ed38e8bef857552f93114b4ee113a880b
github.com/pypa/advisory-database/tree/main/vulns/matrix-synapse/PYSEC-2019-186.yaml
github.com/advisories/GHSA-cppw-2mf8-qpm5
Show 11 moreShow less
security-tracker.debian.org/tracker/CVE-2019-18835
github.com/matrix-org/synapse
ubuntu.com/security/CVE-2019-18835
ubuntu.com/security/notices/USN-6076-1
cve.org/CVERecord?id=CVE-2019-18835
ubuntu.com/security/CVE-2018-10657
ubuntu.com/security/CVE-2018-12291
ubuntu.com/security/CVE-2018-12423
ubuntu.com/security/CVE-2018-16515
ubuntu.com/security/CVE-2019-5885
ubuntu.com/security/CVE-2019-11842
Left out here: 7 versions. The JSON record has them.