CVE-2019-18981
Pimcore Access Control Issues
Pimcore before 6.2.2 lacks an Access Denied outcome for a certain scenario of an incorrect recipient ID of a notification.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Pimcore before 6.2.2 lacks an Access Denied outcome for a certain scenario of an incorrect recipient ID of a notification.
- Record
CVE-2019-18981- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-838
- Updated
- 2026-11-02
CVE List No score
Pimcore before 6.2.2 lacks an Access Denied outcome for a certain scenario of an incorrect recipient ID of a notification.
- Record
CVE-2019-18981- Updated
- 2026-11-02
EUVDEUVD-2022-4373 No score
Pimcore before 6.2.2 lacks an Access Denied outcome for a certain scenario of an incorrect recipient ID of a notification.
- Record
EUVD-2022-4373- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-jhcf-j4hg-v64r
9.8
Pimcore Access Control Issues
Pimcore before 6.2.2 lacks an Access Denied outcome for a certain scenario of an incorrect recipient ID of a notification.
- Record
GHSA-jhcf-j4hg-v64r- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-838
- Updated
- 2026-11-02
OSV
9.8
Pimcore before 6.2.2 lacks an Access Denied outcome for a certain scenario of an incorrect recipient ID of a notification.
- Record
CVE-2019-18981- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-jhcf-j4hg-v64r
9.8
Pimcore Access Control Issues
Pimcore before 6.2.2 lacks an Access Denied outcome for a certain scenario of an incorrect recipient ID of a notification.
- Record
GHSA-jhcf-j4hg-v64r- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-838
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pimcore/pimcorePackagist |
before 6.2.2 | 6.2.2 |
pimcore/pimcorePackagist |
before 6.2.2, plus listed versions 2.2.02.2.12.2.22.3.03.0.0 Show 45 moreShow less3.0.13.0.23.0.33.0.43.0.53.0.63.1.03.1.14.0.04.0.14.1.04.1.14.1.24.1.34.2.04.3.04.3.14.4.04.4.14.4.24.4.34.5.04.6.04.6.14.6.24.6.34.6.44.6.5v5.0.0v5.0.0-RCv5.0.1v5.0.2v5.0.3v5.0.4v5.1.0v5.1.0-alphav5.1.1v5.1.2v5.1.3v5.2.0v5.2.1v5.2.2v5.2.3v5.3.0v5.3.1 |
6.2.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-18981 is a critical vulnerability (CVSS 9.8) in Pimcore, published November 15, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.39%, the 72nd percentile. Fixed in pimcore/pimcore 6.2.2.
References
Left out here: 42 versions. The JSON record has them.