CVE-2019-19609
Duplicate Advisory: OS Command Injection in Strapi
CVE-2019-19609 is a high vulnerability (CVSS 7.2) in Strapi, published December 5, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 54.1%, the 99th percentile. Fixed in strapi 3.0.0-beta.17.8.
The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.2
The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.
- Record
CVE-2019-19609- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 9.0 High
AV:N/AC:L/Au:S/C:C/I:C/A:C - Weakness
- CWE-78
- Updated
- 2026-11-02
CVE List No score
The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.
- Record
CVE-2019-19609- Updated
- 2026-11-02
EUVDEUVD-2021-2436 No score
The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.
- Record
EUVD-2021-2436- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-49vv-6q7q-w5cf
7.2
Duplicate Advisory: OS Command Injection in Strapi
Duplicate Advisory
This advisory has been withdrawn because it is a duplicate of GHSA-9p2w-rmx4-9mw7. This link is maintained to preserve external references.
Original Description
The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.
- Record
GHSA-49vv-6q7q-w5cf- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-78
- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-9p2w-rmx4-9mw7
7.2
Command Injection in strapi
Versions of strapi before 3.0.0-beta.17.8 are vulnerable to Command Injection. The package fails to sanitize plugin names in the /admin/plugins/install/ route. This may allow an authenticated attacker with admin privileges to run arbitrary commands in the server.
Recommendation
Upgrade to version 3.0.0-beta.17.8 or later
- Record
GHSA-9p2w-rmx4-9mw7- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
OSV
7.2
The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.
- Record
CVE-2019-19609- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-49vv-6q7q-w5cf
7.2
Duplicate Advisory: OS Command Injection in Strapi
Duplicate Advisory
This advisory has been withdrawn because it is a duplicate of GHSA-9p2w-rmx4-9mw7. This link is maintained to preserve external references.
Original Description
The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.
- Record
GHSA-49vv-6q7q-w5cf- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-20, CWE-78
- Updated
- 2026-11-02
OSVGHSA-9p2w-rmx4-9mw7
7.2
Command Injection in strapi
Versions of strapi before 3.0.0-beta.17.8 are vulnerable to Command Injection. The package fails to sanitize plugin names in the /admin/plugins/install/ route. This may allow an authenticated attacker with admin privileges to run arbitrary commands in the server.
Recommendation
Upgrade to version 3.0.0-beta.17.8 or later
- Record
GHSA-9p2w-rmx4-9mw7- CVSS 3.1
- 7.2 High
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-77
- Updated
- 2026-11-02
Affected products
Affected packages
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Strapi 3.0.0-beta.17.7 - Remote Code Execution (RCE) (Authenticated) | 2021-08-30 |
| PoC in GitHub | D3m0nicw0lf/CVE-2019-19609 | 2021-09-11 |
| PoC in GitHub | RamPanic/CVE-2019-19609-EXPLOIT | 2021-12-08 |
| PoC in GitHub | diego-tella/CVE-2019-19609-EXPLOIT | 2021-08-29 |
| PoC in GitHub | ebadfd/CVE-2019-19609 | 2021-08-29 |
| PoC in GitHub | glowbase/CVE-2019-19609 | 2022-01-23 |
| PoC in GitHub | guglia001/CVE-2019-19609 | 2021-08-30 |
| PoC in GitHub | n000xy/CVE-2019-19609-POC-Python | 2021-11-27 |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | affected | |
| 2026-11-03 | affected, aliases, cwes, references, title | EUVD |
| 2026-11-02 | created | GitHub Advisories, OSV |
| 2026-11-02 | created | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV, PoC in GitHub |
References
bittherapy.net/post/strapi-framework-remote-code-execution
github.com/strapi/strapi/pull/4636
packetstormsecurity.com/files/163950/Strapi-CMS-3.0.0-beta.17.4-Remote-Code-Execution.html
packetstormsecurity.com/files/163940/Strapi-3.0.0-beta.17.7-Remote-Code-Execution.html
nvd.nist.gov/vuln/detail/CVE-2019-19609
github.com/advisories/GHSA-49vv-6q7q-w5cf
npmjs.com/advisories/1424
github.com/advisories/GHSA-9p2w-rmx4-9mw7
github.com/strapi/strapi