CVE-2019-19830
_core_/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject...
core/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject content into the database.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
core/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject content into the database.
- Record
CVE-2019-19830- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:L/Au:S/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
core/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject content into the database.
- Record
CVE-2019-19830- Updated
- 2026-11-02
EUVDEUVD-2019-9428 No score
core/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject content into the database.
- Record
EUVD-2019-9428- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hrcf-gxm4-f848
6.5
_core_/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject...
core/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject content into the database.
- Record
GHSA-hrcf-gxm4-f848- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSV
6.5
core/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject content into the database.
- Record
CVE-2019-19830- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-19830
6.5
core/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject content into the database.
- Record
DEBIAN-CVE-2019-19830- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-19830
6.5
core/plugins/medias in SPIP 3.2.x before 3.2.7 allows remote authenticated authors to inject content into the database.
- Record
UBUNTU-CVE-2019-19830- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N - Updated
- 2026-11-02
OSVUSN-4536-1 No score
spip vulnerabilities
Youssouf Boulouiz discovered that SPIP incorrectly handled login error messages. A remote attacker could potentially exploit this to conduct cross-site scripting (XSS) attacks. (CVE-2019-16392)
Gilles Vincent discovered that SPIP incorrectly handled password reset requests. A remote attacker could possibly use this issue to cause SPIP to enumerate registered users. (CVE-2019-16394)
Guillaume Fahrner discovered that SPIP did not properly sanitize input. A remote authenticated attacker could possibly use this issue to execute arbitrary code on the host server. (CVE-2019-11071)
Sylvain Lefevre discovered that SPIP incorrectly handled user authorization. A remote attacker could possibly use this issue to modify and publish content and modify the database. (CVE-2019-16391)
It was discovered that SPIP did not properly sanitize input. A remote attacker could, through cross-site scripting (XSS) and PHP injection, exploit this to inject arbitrary web script or HTML. (CVE-2017-15736)
Alexis Zucca discovered that SPIP incorrectly handled the media plugin. A remote authenticated attacker could possibly use this issue to write to the database. (CVE-2019-19830)
Christophe Laffont discovered that SPIP incorrectly handled redirect URLs. An attacker could use this issue to cause SPIP to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2019-16393)
- Record
USN-4536-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
spipDebian:13 |
before 3.2.7-1 | 3.2.7-1 |
spipDebian:14 |
before 3.2.7-1 | 3.2.7-1 |
spipDebian:10 |
before 3.2.4-1+deb10u2, plus listed versions 3.2.4-13.2.4-1+deb10u1 |
3.2.4-1+deb10u2 |
spipUbuntu:18.04:LTS |
before 3.1.4-4~deb9u3build0.18.04.1, plus listed versions 3.1.4-3 |
3.1.4-4~deb9u3build0.18.04.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-19830 is a medium vulnerability (CVSS 6.5) in Spip, published December 13, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.27%, the 69th percentile. Fixed in spip 3.2.7-1.
References
debian.org/security/2019/dsa-4583
blog.spip.net/Mise-a-jour-CRITIQUE-de-securite-sortie-de-SPIP-3-2-7-SPIP-3-1-12.html
zone.spip.net/trac/spip-zone/changeset/118898/spip-zone/_core_/plugins/medias
git.spip.net/SPIP/spip/commit/8eb11ba132b92696eb34d606d71aa8edf40e0f69
usn.ubuntu.com/4536-1
nvd.nist.gov/vuln/detail/CVE-2019-19830
Show 11 moreShow less
github.com/advisories/GHSA-hrcf-gxm4-f848
security-tracker.debian.org/tracker/CVE-2019-19830
ubuntu.com/security/CVE-2019-19830
cve.org/CVERecord?id=CVE-2019-19830
ubuntu.com/security/notices/USN-4536-1
ubuntu.com/security/CVE-2017-15736
ubuntu.com/security/CVE-2019-11071
ubuntu.com/security/CVE-2019-16391
ubuntu.com/security/CVE-2019-16392
ubuntu.com/security/CVE-2019-16393
ubuntu.com/security/CVE-2019-16394