Every CVE Search/ Get API key

CVE-2019-19920

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule....

8.8 HighFix available

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule. This occurs because Greylisting.pm relies on eval (rather than direct parsing and/or use of the taint feature). This issue is similar to CVE-2018-11805.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.25%Up 1.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule. This occurs because Greylisting.pm relies on eval (rather than direct parsing and/or use of the taint feature). This issue is similar to CVE-2018-11805.

Record
CVE-2019-19920
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.0 HighAV:N/AC:L/Au:S/C:C/I:C/A:C
Weakness
CWE-78
Updated
2026-11-02
CVE List No score

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule. This occurs because Greylisting.pm relies on eval (rather than direct parsing and/or use of the taint feature). This issue is similar to CVE-2018-11805.

Record
CVE-2019-19920
Updated
2026-11-02
EUVDEUVD-2019-9510 No score

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule. This occurs because Greylisting.pm relies on eval (rather than direct parsing and/or use of the taint feature). This issue is similar to CVE-2018-11805.

Record
EUVD-2019-9510
Updated
2026-11-03
GitHub AdvisoriesGHSA-28xw-m7jp-89ch 8.8

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule....

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule. This occurs because Greylisting.pm relies on eval (rather than direct parsing and/or use of the taint feature). This issue is similar to CVE-2018-11805.

Record
GHSA-28xw-m7jp-89ch
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-78
Updated
2026-11-02
OSV 8.8

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule. This occurs because Greylisting.pm relies on eval (rather than direct parsing and/or use of the taint feature). This issue is similar to CVE-2018-11805.

Record
CVE-2019-19920
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-19920 8.8

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule. This occurs because Greylisting.pm relies on eval (rather than direct parsing and/or use of the taint feature). This issue is similar to CVE-2018-11805.

Record
DEBIAN-CVE-2019-19920
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-19920 8.8

sa-exim 4.2.1 allows attackers to execute arbitrary code if they can write a .cf file or a rule. This occurs because Greylisting.pm relies on eval (rather than direct parsing and/or use of the taint feature). This issue is similar to CVE-2018-11805.

Record
UBUNTU-CVE-2019-19920
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-4520-1 No score

sa-exim vulnerability

It was discovered that Exim SpamAssassin does not properly handle configuration strings. An attacker could possibly use this issue to execute arbitrary code. (CVE-2019-19920)

Record
USN-4520-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
sa-exim
Debian:12
before 4.2.1-19
4.2.1-19
sa-exim
Debian:13
before 4.2.1-19
4.2.1-19
sa-exim
Debian:8
before 4.2.1-14+deb8u1, plus listed versions
4.2.1-14
4.2.1-14+deb8u1
sa-exim
Ubuntu:16.04:LTS
before 4.2.1-14+deb8u1build0.16.04.1, plus listed versions
4.2.1-14build1
4.2.1-14+deb8u1build0.16.04.1
sa-exim
Ubuntu:18.04:LTS
All versions, plus listed versions
4.2.1-16
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-19920 is a high vulnerability (CVSS 8.8) in Sa-exim Project Sa-exim, published December 22, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.25%, the 88th percentile. Fixed in sa-exim 4.2.1-19.

References

Show 5 moreShow less
MoveEnter Open