CVE-2019-19935
DOM-based cross-site scripting in Froala Editor
Froala Editor before 3.2.3 allows XSS.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
Froala Editor before 3.2.3 allows XSS.
- Record
CVE-2019-19935- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Froala Editor before 3.2.3 allows XSS.
- Record
CVE-2019-19935- Updated
- 2026-11-02
EUVDEUVD-2022-1026 No score
Froala Editor before 3.2.3 allows XSS.
- Record
EUVD-2022-1026- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-h236-g5gh-vq6c
6.1
DOM-based cross-site scripting in Froala Editor
Froala WYSIWYG HTML Editor is a lightweight WYSIWYG HTML Editor written in JavaScript that enables rich text editing capabilities for web applications. A DOM-based cross-site scripting (XSS) vulnerability exists in versions before 3.2.3 because HTML code in the editor is not correctly sanitized when inserted into the DOM. This allows an attacker that can control the editor content to execute arbitrary JavaScript in the context of the victim’s session.
- Record
GHSA-h236-g5gh-vq6c- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
Froala Editor before 3.2.3 allows XSS.
- Record
CVE-2019-19935- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-h236-g5gh-vq6c
6.1
DOM-based cross-site scripting in Froala Editor
Froala WYSIWYG HTML Editor is a lightweight WYSIWYG HTML Editor written in JavaScript that enables rich text editing capabilities for web applications. A DOM-based cross-site scripting (XSS) vulnerability exists in versions before 3.2.3 because HTML code in the editor is not correctly sanitized when inserted into the DOM. This allows an attacker that can control the editor content to execute arbitrary JavaScript in the context of the victim’s session.
- Record
GHSA-h236-g5gh-vq6c- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
froala-editornpm |
before 3.2.3 | 3.2.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-19935 is a medium vulnerability (CVSS 6.1) in Froala Editor, published July 7, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.85%, the 79th percentile. Fixed in froala-editor 3.2.3.
References
github.com/froala/wysiwyg-editor/compare/v3.0.5...v3.0.6
packetstormsecurity.com/files/158300/Froala-WYSIWYG-HTML-Editor-3.1.1-Cross-Site-Scripting.html
snyk.io/vuln/npm:froala-editor
blog.compass-security.com/2020/07/yet-another-froala-0-day-xss
compass-security.com/fileadmin/Datein/Research/Advisories/CSNC-2020-004_DOM_XSS_in_Froala_WYSIWYG_HTML_Editor.txt
nvd.nist.gov/vuln/detail/CVE-2019-19935
froala.com/wysiwyg-editor/changelog
github.com/advisories/GHSA-h236-g5gh-vq6c
github.com/froala/wysiwyg-editor-release