Every CVE Search/ Get API key

CVE-2019-20509

archive_read_support_format_lha.c in libarchive before 3.4.1 does not ensure valid sizes for UTF...

6.5 MediumFix availableRejected

DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it only affected a development version. Notes: none

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

What each source reports

OSV Score usedUBUNTU-CVE-2019-20509 6.5

** REJECT ** DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it only affected a development version. Notes: none.

Record
UBUNTU-CVE-2019-20509
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
CVE List No score

DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it only affected a development version. Notes: none

Record
CVE-2019-20509
Updated
2026-11-02
EUVDEUVD-2019-11053 No score

DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it only affected a development version. Notes: none

Record
EUVD-2019-11053
Updated
2026-11-03
GitHub AdvisoriesGHSA-wpgg-gcgq-v3vh No score

archive_read_support_format_lha.c in libarchive before 3.4.1 does not ensure valid sizes for UTF...

archive_read_support_format_lha.c in libarchive before 3.4.1 does not ensure valid sizes for UTF-16 input, which allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted LHA archive.

Record
GHSA-wpgg-gcgq-v3vh
Updated
2026-11-02
NVD No score

Rejected reason: DO NOT USE THIS CANDIDATE NUMBER. ConsultIDs: none. Reason: This candidate was withdrawn by its CNA. Further investigation showed that it only affected a development version. Notes: none

Record
CVE-2019-20509
Updated
2026-11-02
OSVMGASA-2020-0253 No score

Updated libarchive packages fix security vulnerability

Updated libarchive packages fix security vulnerability:

archive_read_support_format_lha.c in libarchive before 3.4.1 does not ensure valid sizes for UTF-16 input, which allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted LHA archive (CVE-2019-20509).

The libarchive package has been updated to version 3.4.3, fixing this issue and other bugs.

Record
MGASA-2020-0253
Updated
2026-11-02

Affected packages

Affected packages
PackageAffectedFixed
libarchive
Mageia:7
before 3.4.3-1.mga7
3.4.3-1.mga7

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-20509 has been rejected by its source and should not be treated as a live vulnerability, published March 10, 2020. Fixed in libarchive 3.4.3-1.mga7.

References

Show 7 moreShow less
MoveEnter Open