Every CVE Search/ Get API key

CVE-2019-20789

Croos-site scripting in Croogo

4.8 MediumFix available

Croogo before 3.0.7 allows XSS via the title to admin/menus/menus or admin/taxonomy/vocabularies.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.73%Up 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 4.8

Croogo before 3.0.7 allows XSS via the title to admin/menus/menus or admin/taxonomy/vocabularies.

Record
CVE-2019-20789
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

Croogo before 3.0.7 allows XSS via the title to admin/menus/menus or admin/taxonomy/vocabularies.

Record
CVE-2019-20789
Updated
2026-11-02
EUVDEUVD-2021-1342 No score

Croogo before 3.0.7 allows XSS via the title to admin/menus/menus or admin/taxonomy/vocabularies.

Record
EUVD-2021-1342
Updated
2026-11-03
GitHub AdvisoriesGHSA-jfvf-rfmq-qwf8 4.8

Croos-site scripting in Croogo

Croogo before 3.0.7 allows XSS via the title to admin/menus/menus or admin/taxonomy/vocabularies.

Record
GHSA-jfvf-rfmq-qwf8
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 4.8

Croogo before 3.0.7 allows XSS via the title to admin/menus/menus or admin/taxonomy/vocabularies.

Record
CVE-2019-20789
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-jfvf-rfmq-qwf8 4.8

Croos-site scripting in Croogo

Croogo before 3.0.7 allows XSS via the title to admin/menus/menus or admin/taxonomy/vocabularies.

Record
GHSA-jfvf-rfmq-qwf8
CVSS 3.1
4.8 MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
croogo/croogo
Packagist
before 3.0.7
3.0.7
croogo/croogo
Packagist
before 3.0.7, plus listed versions
2.3.33.0.03.0.0-alpha.13.0.0-alpha.23.0.0-alpha.3
Show 20 moreShow less
3.0.0-alpha.43.0.0-beta.13.0.13.0.23.0.33.0.43.0.53.0.6v2.0.0v2.1.0v2.1.1v2.1.2v2.2.0v2.2.1v2.2.2v2.2.3v2.2.4v2.3.0v2.3.1v2.3.2
3.0.7

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-20789 is a medium vulnerability (CVSS 4.8) in Croogo, published April 26, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.73%, the 54th percentile. Fixed in croogo/croogo 3.0.7.

References

MoveEnter Open