CVE-2019-2180
In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due...
In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure from the printer service with no additional execution privileges needed. User interaction is not needed for exploitation.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.5
In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure from the printer service with no additional execution privileges needed. User interaction is not needed for exploitation.
- Record
CVE-2019-2180- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 2.1 Low
AV:L/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-125
- Updated
- 2026-11-02
CVE List No score
In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure from the printer service with no additional execution privileges needed. User interaction is not needed for exploitation.
- Record
CVE-2019-2180- Updated
- 2026-11-02
EUVDEUVD-2019-11822 No score
In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure from the printer service with no additional execution privileges needed. User interaction is not needed for exploitation.
- Record
EUVD-2019-11822- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-f5ff-4pfm-qv6p No score
In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due...
In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure from the printer service with no additional execution privileges needed. User interaction is not needed for exploitation.
- Record
GHSA-f5ff-4pfm-qv6p- Updated
- 2026-11-02
OSV
5.5
In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure from the printer service with no additional execution privileges needed. User interaction is not needed for exploitation.
- Record
CVE-2019-2180- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-2180
5.5
In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure from the printer service with no additional execution privileges needed. User interaction is not needed for exploitation.
- Record
DEBIAN-CVE-2019-2180- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-2180
5.5
In ippSetValueTag of ipp.c in Android 8.0, 8.1 and 9, there is a possible out of bounds read due to improper input validation. This could lead to local information disclosure from the printer service with no additional execution privileges needed. User interaction is not needed for exploitation.
- Record
UBUNTU-CVE-2019-2180- CVSS 3.0
- 5.5 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
cupsDebian:12 |
before 2.2.12-1 | 2.2.12-1 |
cupsDebian:13 |
before 2.2.12-1 | 2.2.12-1 |
cupsDebian:14 |
before 2.2.12-1 | 2.2.12-1 |
cupsDebian:8 From an advisory covering 3 CVEs |
before 1.7.5-11+deb8u5, plus listed versions 1.7.5-111.7.5-11+deb8u11.7.5-11+deb8u21.7.5-11+deb8u31.7.5-11+deb8u4 |
1.7.5-11+deb8u5 |
cupsUbuntu:16.04:LTS |
before 2.1.3-4ubuntu0.10, plus listed versions 2.1.0-4ubuntu32.1.0-52.1.0-62.1.0-6ubuntu12.1.0-7 Show 14 moreShow less2.1.2-12.1.2-22.1.3-12.1.3-1build12.1.3-32.1.3-42.1.3-4ubuntu0.22.1.3-4ubuntu0.32.1.3-4ubuntu0.42.1.3-4ubuntu0.52.1.3-4ubuntu0.62.1.3-4ubuntu0.72.1.3-4ubuntu0.82.1.3-4ubuntu0.9 |
2.1.3-4ubuntu0.10 |
cupsUbuntu:18.04:LTS |
before 2.2.7-1ubuntu2.7, plus listed versions 2.2.4-7ubuntu22.2.5-22.2.6-22.2.6-32.2.6-4 Show 9 moreShow less2.2.6-52.2.7-1ubuntu12.2.7-1ubuntu22.2.7-1ubuntu2.12.2.7-1ubuntu2.22.2.7-1ubuntu2.32.2.7-1ubuntu2.42.2.7-1ubuntu2.52.2.7-1ubuntu2.6 |
2.2.7-1ubuntu2.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-2180 is a medium vulnerability (CVSS 5.5) in Google Android, published August 22, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.18%, the 7th percentile. Fixed in cups 2.2.12-1.