CVE-2019-25028
Stored cross-site scripting in Grid component in Vaadin 7 and 8
Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.4
Stored cross-site scripting in Grid component in Vaadin 7 and 8
Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector
- Record
CVE-2019-25028- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N - Weakness
- CWE-80
- Updated
- 2026-11-02
EUVDEUVD-2021-0858
5.4
Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector
- Record
EUVD-2021-0858- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q74r-4xw3-ppx9
5.4
Stored cross-site scripting in Grid component in Vaadin 7 and 8
Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector.
- Record
GHSA-q74r-4xw3-ppx9- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N - Weakness
- CWE-79, CWE-80
- Updated
- 2026-11-02
NVD
5.4
Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector
- Record
CVE-2019-25028- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N - CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-80, CWE-79
- Updated
- 2026-11-02
OSV
6.1
Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector
- Record
CVE-2019-25028- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-q74r-4xw3-ppx9
5.4
Stored cross-site scripting in Grid component in Vaadin 7 and 8
Missing variable sanitization in Grid component in com.vaadin:vaadin-server versions 7.4.0 through 7.7.19 (Vaadin 7.4.0 through 7.7.19), and 8.0.0 through 8.8.4 (Vaadin 8.0.0 through 8.8.4) allows attacker to inject malicious JavaScript via unspecified vector.
- Record
GHSA-q74r-4xw3-ppx9- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N - Weakness
- CWE-79, CWE-80
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
com.vaadin:vaadin-bomMaven |
7.4.0 up to 7.7.20 | 7.7.20 |
com.vaadin:vaadin-bomMaven |
8.0.0 up to 8.8.5 | 8.8.5 |
com.vaadin:vaadin-serverMaven |
7.4.0 up to 7.7.20 | 7.7.20 |
com.vaadin:vaadin-serverMaven |
8.0.0 up to 8.8.5 | 8.8.5 |
com.vaadin:vaadin-bomMaven |
7.4.0 up to 7.7.20, plus listed versions 7.4.17.4.27.4.37.4.47.4.5 Show 45 moreShow less7.4.67.4.77.4.87.5.07.5.0.beta17.5.0.beta27.5.0.beta37.5.0.rc17.5.0.rc27.5.17.5.107.5.27.5.37.5.47.5.57.5.67.5.77.5.87.5.97.6.07.6.0.alpha17.6.0.alpha27.6.17.6.27.6.37.6.47.6.57.6.67.6.77.6.87.7.07.7.17.7.107.7.117.7.127.7.137.7.147.7.157.7.167.7.177.7.27.7.37.7.47.7.57.7.6 |
7.7.20 |
com.vaadin:vaadin-bomMaven |
8.0.0 up to 8.8.5, plus listed versions 8.0.18.0.28.0.38.0.48.0.5 Show 40 moreShow less8.0.68.0.78.1.08.1.18.1.28.1.38.1.48.1.58.1.68.1.78.1.88.2.08.2.18.3.08.3.18.3.28.3.38.4.08.4.18.4.28.4.38.4.48.4.58.5.08.5.18.5.28.6.08.6.18.6.28.6.38.6.48.7.08.7.0.beta18.7.18.7.28.8.08.8.18.8.28.8.38.8.4 |
8.8.5 |
com.vaadin:vaadin-serverMaven |
7.4.0 up to 7.7.20, plus listed versions 7.4.17.4.27.4.37.4.47.4.5 Show 45 moreShow less7.4.67.4.77.4.87.5.07.5.0.alpha17.5.0.beta17.5.0.beta27.5.0.beta37.5.0.rc17.5.0.rc27.5.17.5.107.5.27.5.37.5.47.5.57.5.67.5.77.5.87.5.97.6.07.6.0.alpha17.6.0.alpha27.6.17.6.27.6.37.6.47.6.57.6.67.6.77.6.87.7.07.7.17.7.107.7.117.7.127.7.137.7.147.7.157.7.167.7.177.7.27.7.37.7.47.7.5 |
7.7.20 |
com.vaadin:vaadin-serverMaven |
8.0.0 up to 8.8.5, plus listed versions 8.0.18.0.28.0.38.0.48.0.5 Show 40 moreShow less8.0.68.0.78.1.08.1.18.1.28.1.38.1.48.1.58.1.68.1.78.1.88.2.08.2.18.3.08.3.18.3.28.3.38.4.08.4.18.4.28.4.38.4.48.4.58.5.08.5.18.5.28.6.08.6.18.6.28.6.38.6.48.7.08.7.0.beta18.7.18.7.28.8.08.8.18.8.28.8.38.8.4 |
8.8.5 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-25028 is a medium vulnerability (CVSS 5.4) in Vaadin, published April 19, 2021. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.92%, the 60th percentile. Fixed in com.vaadin:vaadin-bom 7.7.20.
References
Left out here: 7 versions. The JSON record has them.