Every CVE Search/ Get API key

CVE-2019-25055

Duplicate Advisory: Uncaught Exception in libpulse-binding

7.5 HighFix available

An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.22%Up 0.6 points since Dec 27, 2021
90%50%10%1%

What each source reports

NVD Score used 7.5

An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.

Record
CVE-2019-25055
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Updated
2026-11-02
CVE List No score

An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.

Record
CVE-2019-25055
Updated
2026-11-02
EUVDEUVD-2022-0748 No score

An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.

Record
EUVD-2022-0748
Updated
2026-11-03
GitHub AdvisoriesGHSA-xvcg-2q82-r87j 7.5

Panic mishandled in libpulse-binding

An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.

Record
GHSA-xvcg-2q82-r87j
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-248
Updated
2026-11-02
GitHub AdvisoriesGHSA-wcxc-jf6c-8rx9 No score

Duplicate Advisory: Uncaught Exception in libpulse-binding

Duplicate Advisory

This advisory has been withdrawn because it is a duplicate of GHSA-xvcg-2q82-r87j. This link is maintained to preserve external references.

Original Description

Affected versions of this crate failed to catch panics crossing FFI boundaries via callbacks, which is a form of UB. This flaw was corrected by [this commit][1] which was included in version 2.6.0.

Record
GHSA-wcxc-jf6c-8rx9
Weakness
CWE-248
Updated
2026-11-02
OSV 7.5

An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.

Record
CVE-2019-25055
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-xvcg-2q82-r87j 7.5

Panic mishandled in libpulse-binding

An issue was discovered in the libpulse-binding crate before 2.6.0 for Rust. It mishandles a panic that crosses a Foreign Function Interface (FFI) boundary.

Record
GHSA-xvcg-2q82-r87j
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-248
Updated
2026-11-02
OSVGHSA-wcxc-jf6c-8rx9 No score

Duplicate Advisory: Uncaught Exception in libpulse-binding

Duplicate Advisory

This advisory has been withdrawn because it is a duplicate of GHSA-xvcg-2q82-r87j. This link is maintained to preserve external references.

Original Description

Affected versions of this crate failed to catch panics crossing FFI boundaries via callbacks, which is a form of UB. This flaw was corrected by [this commit][1] which was included in version 2.6.0.

Record
GHSA-wcxc-jf6c-8rx9
Weakness
CWE-248
Updated
2026-11-02
OSVRUSTSEC-2019-0038 No score

Fix for UB in failure to catch panics crossing FFI boundaries

Affected versions of this crate failed to catch panics crossing FFI boundaries via callbacks, which is a form of UB. This flaw was corrected by this commit which was included in version 2.6.0.

Record
RUSTSEC-2019-0038
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
libpulse-binding
crates.io
before 2.6.0
2.6.0
libpulse-binding
crates.io
0.0.0-0 up to 2.6.0
2.6.0

History

History
RecordedChangedSources
affected
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-25055 is a high vulnerability (CVSS 7.5) in Libpulse-binding Project Libpulse-binding, published March 10, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.22%, the 68th percentile. Fixed in libpulse-binding 2.6.0.

References

MoveEnter Open