CVE-2019-25067
Podman/Varlink API Privilege Escalation
A vulnerability, which was classified as critical, was found in Podman and Varlink 1.5.1. This affects an unknown part of the component API. The manipulation leads to Remote Privilege Escalation. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-143949 was assigned to this vulnerability.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
6.3
Podman/Varlink API Privilege Escalation
A vulnerability, which was classified as critical, was found in Podman and Varlink 1.5.1. This affects an unknown part of the component API. The manipulation leads to Remote Privilege Escalation. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-143949 was assigned to this vulnerability.
- Record
CVE-2019-25067- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - CVSS 3.0
- 6.3 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - CVSS 2.0
- 6.0
AV:N/AC:M/Au:S/C:P/I:P/A:P - Updated
- 2026-11-02
EUVDEUVD-2019-11512
6.3
A vulnerability, which was classified as critical, was found in Podman and Varlink 1.5.1. This affects an unknown part of the component API. The manipulation leads to Remote Privilege Escalation. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-143949 was assigned to this vulnerability.
- Record
EUVD-2019-11512- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-vjwp-mggj-92gq
8.8
A vulnerability, which was classified as critical, was found in Podman and Varlink 1.5.1. This...
A vulnerability, which was classified as critical, was found in Podman and Varlink 1.5.1. This affects an unknown part of the component API. The manipulation leads to Privilege Escalation. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used.
- Record
GHSA-vjwp-mggj-92gq- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
NVD
6.3
A vulnerability, which was classified as critical, was found in Podman and Varlink 1.5.1. This affects an unknown part of the component API. The manipulation leads to Remote Privilege Escalation. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-143949 was assigned to this vulnerability.
- Record
CVE-2019-25067- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.0 Medium
AV:N/AC:M/Au:S/C:P/I:P/A:P - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Updated
- 2026-11-02
OSV
8.8
A vulnerability, which was classified as critical, was found in Podman and Varlink 1.5.1. This affects an unknown part of the component API. The manipulation leads to Remote Privilege Escalation. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-143949 was assigned to this vulnerability.
- Record
CVE-2019-25067- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-25067
8.8
A vulnerability, which was classified as critical, was found in Podman and Varlink 1.5.1. This affects an unknown part of the component API. The manipulation leads to Remote Privilege Escalation. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-143949 was assigned to this vulnerability.
- Record
DEBIAN-CVE-2019-25067- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-25067
6.3
A vulnerability, which was classified as critical, was found in Podman and Varlink 1.5.1. This affects an unknown part of the component API. The manipulation leads to Remote Privilege Escalation. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. The identifier VDB-143949 was assigned to this vulnerability.
- Record
UBUNTU-CVE-2019-25067- CVSS 3.1
- 6.3 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
libpodDebian:12 |
before 3.0.0+dfsg1-1 | 3.0.0+dfsg1-1 |
libpodUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 3.2.1+ds1-2ubuntu33.4.4+ds1-1ubuntu13.4.4+ds1-1ubuntu1.22.04.13.4.4+ds1-1ubuntu1.22.04.23.4.4+ds1-1ubuntu1.22.04.33.4.4+ds1-1ubuntu1.22.04.3+esm13.4.4+ds1-1ubuntu1.22.04.3+esm23.4.4+ds1-1ubuntu1.22.04.3+esm3 |
None known |
libpodUbuntu:Pro:24.04:LTS |
All versions, plus listed versions 4.3.1+ds1-84.7.2+ds1-24.7.2+ds1-2build14.8.3+ds1-24.9.0+ds1-2 Show 8 moreShow less4.9.3+ds1-14.9.3+ds1-1build14.9.3+ds1-1build24.9.3+ds1-1ubuntu0.14.9.3+ds1-1ubuntu0.24.9.3+ds1-1ubuntu0.2+esm14.9.3+ds1-1ubuntu0.2+esm24.9.3+ds1-1ubuntu0.2+esm3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-25067 is a medium vulnerability (CVSS 6.3) in Containers Podman, published June 9, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.59%, the 85th percentile. Fixed in libpod 3.0.0+dfsg1-1.
References
vuldb.com?id.143949
vuldb.com?ctiid.143949
exploit-db.com/exploits/47500
github.com/containers/podman/issues/21628
nvd.nist.gov/vuln/detail/CVE-2019-25067
github.com/advisories/GHSA-vjwp-mggj-92gq
security-tracker.debian.org/tracker/CVE-2019-25067
ubuntu.com/security/CVE-2019-25067
cve.org/CVERecord?id=CVE-2019-25067