Every CVE Search/ Get API key

CVE-2019-3465

Signature validation bypass in XmlSecLibs

8.8 HighFix available

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.99%Down 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Record
CVE-2019-3465
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.5 MediumAV:N/AC:L/Au:S/C:P/I:P/A:P
Weakness
CWE-347
Updated
2026-11-02
CVE List No score

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Record
CVE-2019-3465
Updated
2026-11-02
EUVDEUVD-2019-0760 No score

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Record
EUVD-2019-0760
Updated
2026-11-03
GitHub AdvisoriesGHSA-pqm6-cgwr-x6pf 8.8

Signature validation bypass in XmlSecLibs

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Record
GHSA-pqm6-cgwr-x6pf
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-347
Updated
2026-11-02
OSV 8.8

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Record
CVE-2019-3465
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-3465 8.8

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Record
DEBIAN-CVE-2019-3465
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-pqm6-cgwr-x6pf 8.8

Signature validation bypass in XmlSecLibs

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Record
GHSA-pqm6-cgwr-x6pf
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-347
Updated
2026-11-02
OSVUBUNTU-CVE-2019-3465 8.8

Rob Richards XmlSecLibs, all versions prior to v3.0.3, as used for example by SimpleSAMLphp, performed incorrect validation of cryptographic signatures in XML messages, allowing an authenticated attacker to impersonate others or elevate privileges by creating a crafted XML message.

Record
UBUNTU-CVE-2019-3465
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-8770-1 No score

simplesamlphp vulnerabilities

It was discovered that SimpleSAMLphp incorrectly validated cryptographic signatures in XML messages. An authenticated attacker could possibly use this issue to impersonate users or gain elevated privileges. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2019-3465)

It was discovered that SimpleSAMLphp incorrectly handled external entities when parsing untrusted XML documents. A remote attacker could possibly use this issue to obtain sensitive information. This issue did not affect Ubuntu 24.04 LTS. (CVE-2024-52596)

It was discovered that SimpleSAMLphp incorrectly verified signatures in SAML messages using the HTTP-Redirect binding. A remote attacker could possibly use this issue to bypass authentication and impersonate users. (CVE-2025-27773)

Record
USN-8770-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
robrichards/xmlseclibs
Packagist
3.0.0 up to 3.0.4
3.0.4
robrichards/xmlseclibs
Packagist
1.0.0 up to 2.1.1
2.1.1
simplesamlphp
Debian:12
before 1.17.6-2
1.17.6-2
simplesamlphp
Debian:14
before 1.17.6-2, plus listed versions
1.10.0-11.11.0-11.12.0-11.12.0~rc1-11.12.0~rc2-1
Show 45 moreShow less
1.13.0-11.13.1-11.13.1-21.13.2-11.14.0-11.14.1-11.14.10-11.14.11-11.14.15-11.14.2-11.14.2-21.14.3-11.14.4-11.14.5-11.14.6-11.14.7-11.14.8-11.14.9-11.15.0-11.15.1-11.15.2-11.15.3-11.15.4-11.16.0-11.16.1-11.16.2-11.16.3-11.17.0-11.17.1-11.17.2-11.17.2-21.17.3-11.17.4-11.17.5-11.17.6-11.6.0-11.6.1-11.6.2-11.6.3-11.6.3-21.6.3-31.7.0-11.7.0-21.8.0-11.8.1-1
1.17.6-2
simplesamlphp
Debian:8
before 1.13.1-2+deb8u3, plus listed versions
1.13.1-21.13.1-2+deb8u11.13.1-2+deb8u2
1.13.1-2+deb8u3
simplesamlphp
Debian:9
before 1.14.11-1+deb9u2, plus listed versions
1.14.11-11.14.11-1+deb9u1
1.14.11-1+deb9u2
simplesamlphp
Debian:10
before 1.16.3-1+deb10u1, plus listed versions
1.16.3-1
1.16.3-1+deb10u1
robrichards/xmlseclibs
Packagist
3.0.0 up to 3.0.4, plus listed versions
3.0.13.0.23.0.3
3.0.4
robrichards/xmlseclibs
Packagist
1.0.0 up to 2.1.1, plus listed versions
1.3.21.3.31.3.41.4.01.4.1
Show 5 moreShow less
1.4.21.4.32.0.02.0.12.1.0
2.1.1
simplesamlphp
Ubuntu:Pro:16.04:LTS
before 1.14.0-1ubuntu2+esm1, plus listed versions
1.13.2-11.14.0-11.14.0-1ubuntu2
1.14.0-1ubuntu2+esm1
Show 4 moreShow less
Affected packages
PackageAffectedFixed
simplesamlphp
Ubuntu:Pro:18.04:LTS
before 1.15.3-1ubuntu0.1~esm1, plus listed versions
1.14.15-11.15.0-11.15.1-11.15.2-11.15.3-1
1.15.3-1ubuntu0.1~esm1
simplesamlphp
Ubuntu:Pro:20.04:LTS
before 1.18.4-1ubuntu0.1~esm1, plus listed versions
1.17.5-11.17.6-11.17.6-21.18.1-11.18.4-1
1.18.4-1ubuntu0.1~esm1
simplesamlphp
Ubuntu:Pro:22.04:LTS
before 1.19.1-1.1ubuntu0.1~esm1, plus listed versions
1.19.1-11.19.1-1.1
1.19.1-1.1ubuntu0.1~esm1
simplesamlphp
Ubuntu:24.04:LTS
before 1.19.7-1+deb12u1ubuntu0.1, plus listed versions
1.19.7-1
1.19.7-1+deb12u1ubuntu0.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-3465 is a high vulnerability (CVSS 8.8) in Simplesamlphp, published November 6, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.99%, the 87th percentile. Fixed in robrichards/xmlseclibs 3.0.4.

References

Show 28 moreShow less
This page doesn't list everything

Left out here: 6 versions. The JSON record has them.

MoveEnter Open