Every CVE Search/ Get API key

CVE-2019-3852

Moodle context freezing

4.3 MediumFix available

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
Low
Availability
None

Exploit likelihood

1.06%Up 0.4 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 4.3

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

Record
CVE-2019-3852
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
EUVDEUVD-2022-5264 4.3

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

Record
EUVD-2022-5264
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-v2rh-5v88-rgvh 4.3

Moodle context freezing

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

Record
GHSA-v2rh-5v88-rgvh
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
NVD 4.3

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

Record
CVE-2019-3852
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
CVSS 2.0
4.0 MediumAV:N/AC:L/Au:S/C:N/I:P/A:N
Updated
2026-11-02
OSV 4.3

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

Record
CVE-2019-3852
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVGHSA-v2rh-5v88-rgvh 4.3

Moodle context freezing

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

Record
GHSA-v2rh-5v88-rgvh
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2019-3852 4.3

A vulnerability was found in moodle before version 3.6.3. The get_with_capability_join and get_users_by_capability functions were not taking context freezing into account when checking user capabilities

Record
UBUNTU-CVE-2019-3852
CVSS 3.0
4.3 MediumCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
moodle/moodle
Packagist
3.6 up to 3.6.3
3.6.3
moodle/moodle
Packagist
3.6 up to 3.6.3, plus listed versions
v3.6.0v3.6.0-betav3.6.0-rc1v3.6.0-rc2v3.6.0-rc3v3.6.1v3.6.2
3.6.3
moodle
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known
moodle
Ubuntu:Pro:18.04:LTS
All versions, plus listed versions
3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-3852 is a medium vulnerability (CVSS 4.3) in [unknown] Moodle, published March 26, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.06%, the 64th percentile. Fixed in moodle/moodle 3.6.3.

References

Show 5 moreShow less
MoveEnter Open