Every CVE Search/ Get API key

CVE-2019-5414

Command Injection in kill-port

8.1 HighPublic exploitFix available

If an attacker can control the port, which in itself is a very sensitive value, they can inject arbitrary OS commands due to the usage of the exec function in a third-party module kill-port < 1.3.2.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

1.89%Unchanged since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.1

If an attacker can control the port, which in itself is a very sensitive value, they can inject arbitrary OS commands due to the usage of the exec function in a third-party module kill-port < 1.3.2.

Record
CVE-2019-5414
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
9.3 HighAV:N/AC:M/Au:N/C:C/I:C/A:C
Weakness
CWE-77, CWE-78
Updated
2026-11-02
CVE List No score

If an attacker can control the port, which in itself is a very sensitive value, they can inject arbitrary OS commands due to the usage of the exec function in a third-party module kill-port < 1.3.2.

Record
CVE-2019-5414
Weakness
CWE-77
Updated
2026-11-02
EUVDEUVD-2019-0389 No score

If an attacker can control the port, which in itself is a very sensitive value, they can inject arbitrary OS commands due to the usage of the exec function in a third-party module kill-port < 1.3.2.

Record
EUVD-2019-0389
Updated
2026-11-03
GitHub AdvisoriesGHSA-pmv6-gf98-p3r5 8.1

Command Injection in kill-port

Versions of kill-port prior to 1.3.2 are vulnerable to Command Injection. The package does not validate user input on the kill function. This may allow attackers to run arbitrary commands in the system if user input (such as the port number) is passed directly to the function.

Recommendation

Upgrade to version 1.3.2 or later.

Record
GHSA-pmv6-gf98-p3r5
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02
OSV 8.1

If an attacker can control the port, which in itself is a very sensitive value, they can inject arbitrary OS commands due to the usage of the exec function in a third-party module kill-port < 1.3.2.

Record
CVE-2019-5414
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-pmv6-gf98-p3r5 8.1

Command Injection in kill-port

Versions of kill-port prior to 1.3.2 are vulnerable to Command Injection. The package does not validate user input on the kill function. This may allow attackers to run arbitrary commands in the system if user input (such as the port number) is passed directly to the function.

Recommendation

Upgrade to version 1.3.2 or later.

Record
GHSA-pmv6-gf98-p3r5
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-77
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
kill-port
npm
before 1.3.2
1.3.2

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubcrstaicu/CVE-2019-54142025-12-21

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-5414 is a high vulnerability (CVSS 8.1) in Kill-port Project Kill-port, published March 17, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.89%, the 79th percentile. Fixed in kill-port 1.3.2.

References

MoveEnter Open