Every CVE Search/ Get API key

CVE-2019-5729

splunk-sdk does not properly verify untrusted TLS server certificates

8.1 HighFix available

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.70%Up 0.3 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.1

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.

Record
CVE-2019-5729
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.

Record
CVE-2019-5729
Updated
2026-11-02
EUVDEUVD-2019-0131 No score

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.

Record
EUVD-2019-0131
Updated
2026-11-03
GitHub AdvisoriesGHSA-f58w-649r-qjr9 9.2

splunk-sdk does not properly verify untrusted TLS server certificates

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.

Record
GHSA-f58w-649r-qjr9
CVSS 4.0
9.2 CriticalCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-295
Updated
2026-11-02
OSV 8.1

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.

Record
CVE-2019-5729
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-f58w-649r-qjr9 9.2

splunk-sdk does not properly verify untrusted TLS server certificates

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.

Record
GHSA-f58w-649r-qjr9
CVSS 4.0
9.2 CriticalCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.0
8.1 HighCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-295
Updated
2026-11-02
OSVPYSEC-2019-203 No score

Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.

Record
PYSEC-2019-203
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
splunk-sdk
PyPI
before 1.6.6
1.6.6
splunk-sdk
PyPI
before 1.6.6, plus listed versions
0.1.00.1.0a0.8.01.0.01.1.0
Show 14 moreShow less
1.2.01.2.11.2.21.2.31.3.01.3.11.4.01.5.01.6.01.6.11.6.21.6.31.6.41.6.5
1.6.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-5729 is a high vulnerability (CVSS 8.1) in Splunk Software Development Kit, published March 19, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.70%, the 53rd percentile. Fixed in splunk-sdk 1.6.6.

References

MoveEnter Open