CVE-2019-5882
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
- Record
CVE-2019-5882- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-416
- Updated
- 2026-11-02
CVE List No score
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
- Record
CVE-2019-5882- Updated
- 2026-11-02
EUVDEUVD-2019-15453 No score
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
- Record
EUVD-2019-15453- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-843w-9chm-9mvw
9.8
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
- Record
GHSA-843w-9chm-9mvw- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-416
- Updated
- 2026-11-02
OSVALPINE-CVE-2019-5882
9.8
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
- Record
ALPINE-CVE-2019-5882- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSV
9.8
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
- Record
CVE-2019-5882- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2019-5882
9.8
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
- Record
DEBIAN-CVE-2019-5882- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-5882
9.8
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
- Record
UBUNTU-CVE-2019-5882- CVSS 3.0
- 9.8 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVMGASA-2019-0091 No score
Updated irssi packages fix security vulnerability
It was discovered that Irssi incorrectly handled certain inputs. An attacker could possibly use this issue to cause a denial of service or to execute arbitrary code (CVE-2019-5882).
- Record
MGASA-2019-0091- Updated
- 2026-11-02
OSVopenSUSE-SU-2019:0048-1 No score
Security update for irssi
This update for irssi fixes the following issues:
- CVE-2019-5882: Use after free when hidden lines were expired from the scroll buffer (boo#1121396)
This update to the 1.1.2 version also fixes a number of stability issues and bugs.
- Record
openSUSE-SU-2019:0048-1- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10865-1 No score
irssi-1.2.3-2.4 on GA media
These are all security issues fixed in the irssi-1.2.3-2.4 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10865-1- Updated
- 2026-11-02
OSVUSN-3862-1 No score
irssi vulnerability
It was discovered that Irssi incorrectly handled certain inputs. An attacker could possibly use this issue to cause a denial of service or to execute arbitrary code.
- Record
USN-3862-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
irssiAlpine:v3.10 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.11 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.12 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.13 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.14 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.15 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.16 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.17 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.18 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.19 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
Show 18 moreShow less
| Package | Affected | Fixed |
|---|---|---|
irssiAlpine:v3.20 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.21 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.22 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.23 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.24 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.8 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiAlpine:v3.9 |
1.1.0 up to 1.1.2-r0 | 1.1.2-r0 |
irssiDebian:12 |
before 1.1.2-1 | 1.1.2-1 |
irssiDebian:13 |
before 1.1.2-1 | 1.1.2-1 |
irssiDebian:14 |
before 1.1.2-1 | 1.1.2-1 |
irssiMageia:6 |
before 1.0.7-1.1.mga6 | 1.0.7-1.1.mga6 |
irssiUbuntu:14.04:LTS |
before 0.8.15-5ubuntu3.6, plus listed versions 0.8.15-5ubuntu20.8.15-5ubuntu30.8.15-5ubuntu3.10.8.15-5ubuntu3.20.8.15-5ubuntu3.30.8.15-5ubuntu3.40.8.15-5ubuntu3.5 |
0.8.15-5ubuntu3.6 |
irssiUbuntu:16.04:LTS |
before 0.8.19-1ubuntu1.8, plus listed versions 0.8.17-1ubuntu10.8.17-1ubuntu20.8.18-1ubuntu10.8.19-1ubuntu10.8.19-1ubuntu1.2 Show 5 moreShow less0.8.19-1ubuntu1.30.8.19-1ubuntu1.40.8.19-1ubuntu1.50.8.19-1ubuntu1.60.8.19-1ubuntu1.7 |
0.8.19-1ubuntu1.8 |
irssiUbuntu:18.04:LTS |
before 1.0.5-1ubuntu4.1, plus listed versions 1.0.4-1ubuntu21.0.4-1ubuntu31.0.4-1ubuntu41.0.5-1ubuntu11.0.5-1ubuntu21.0.5-1ubuntu31.0.5-1ubuntu4 |
1.0.5-1ubuntu4.1 |
irssiSUSE:Package Hub 12 |
before 1.1.2-bp150.3.4.1 | 1.1.2-bp150.3.4.1 |
irssiSUSE:Package Hub 15 |
before 1.1.2-bp150.3.4.1 | 1.1.2-bp150.3.4.1 |
irssiopenSUSE:Leap 15.0 |
before 1.1.2-bp150.3.4.1 | 1.1.2-bp150.3.4.1 |
irssiopenSUSE:Tumbleweed From an advisory covering 26 CVEs |
before 1.2.3-2.4 | 1.2.3-2.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| affected | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-5882 is a critical vulnerability (CVSS 9.8) in Irssi, published January 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.54%, the 85th percentile. Fixed in irssi 1.1.2-r0.
References
irssi.org/security/irssi_sa_2019_01.txt
irssi.org/NEWS
github.com/irssi/irssi/pull/948
usn.ubuntu.com/3862-1
nvd.nist.gov/vuln/detail/CVE-2019-5882
github.com/advisories/GHSA-843w-9chm-9mvw
Show 35 moreShow less
security.alpinelinux.org/vuln/CVE-2019-5882
security-tracker.debian.org/tracker/CVE-2019-5882
advisories.mageia.org/MGASA-2019-0091.html
bugs.mageia.org/show_bug.cgi?id=24207
ubuntu.com/security/CVE-2019-5882
ubuntu.com/security/notices/USN-3862-1
cve.org/CVERecord?id=CVE-2019-5882
lists.opensuse.org/archives/list/[email protected]/thread/EKYFN6CBVBNNWGETNO3E5L265NZTS7HI
bugzilla.suse.com/1121396
suse.com/security/cve/CVE-2019-5882
suse.com/security/cve/CVE-2017-10965
suse.com/security/cve/CVE-2017-10966
suse.com/security/cve/CVE-2017-15227
suse.com/security/cve/CVE-2017-15228
suse.com/security/cve/CVE-2017-15721
suse.com/security/cve/CVE-2017-15722
suse.com/security/cve/CVE-2017-15723
suse.com/security/cve/CVE-2017-5193
suse.com/security/cve/CVE-2017-5194
suse.com/security/cve/CVE-2017-5195
suse.com/security/cve/CVE-2017-5196
suse.com/security/cve/CVE-2017-5356
suse.com/security/cve/CVE-2017-9468
suse.com/security/cve/CVE-2017-9469
suse.com/security/cve/CVE-2018-5205
suse.com/security/cve/CVE-2018-5206
suse.com/security/cve/CVE-2018-5207
suse.com/security/cve/CVE-2018-5208
suse.com/security/cve/CVE-2018-7050
suse.com/security/cve/CVE-2018-7051
suse.com/security/cve/CVE-2018-7052
suse.com/security/cve/CVE-2018-7053
suse.com/security/cve/CVE-2018-7054
suse.com/security/cve/CVE-2019-13045
suse.com/security/cve/CVE-2019-15717