Every CVE Search/ Get API key

CVE-2019-6338

third-party PEAR Archive_Tar library updates

8.0 HighFix available

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

2.12%Up 1.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.0

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Record
CVE-2019-6338
CVSS 3.0
8.0 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.0 MediumAV:N/AC:M/Au:S/C:P/I:P/A:P
Weakness
CWE-502
Updated
2026-11-02
CVE List No score

third-party PEAR Archive_Tar library updates

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Record
CVE-2019-6338
Updated
2026-11-02
EUVDEUVD-2019-0782 No score

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Record
EUVD-2019-0782
Updated
2026-11-03
GitHub AdvisoriesGHSA-6rmq-x2hv-vxpp 8.0

Drupal core third-party PEAR Archive_Tar library is vulnerable to Deserialization of Untrusted Data

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Record
GHSA-6rmq-x2hv-vxpp
CVSS 3.0
8.0 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSV 8.0

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Record
CVE-2019-6338
CVSS 3.0
8.0 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVGHSA-6rmq-x2hv-vxpp 8.0

Drupal core third-party PEAR Archive_Tar library is vulnerable to Deserialization of Untrusted Data

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Record
GHSA-6rmq-x2hv-vxpp
CVSS 3.0
8.0 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-502
Updated
2026-11-02
OSVUBUNTU-CVE-2019-6338 8.0

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details

Record
UBUNTU-CVE-2019-6338
CVSS 3.0
8.0 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDRUPAL-CORE-2019-001 No score

Drupal core uses the third-party PEAR Archive_Tar library. This library has released a security update which impacts some Drupal configurations. Refer to CVE-2018-1000888 for details.

Record
DRUPAL-CORE-2019-001
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
drupal/drupal
Packagist
7.0.0 up to 7.62.0
7.62.0
drupal/drupal
Packagist
8.0.0 up to 8.5.9
8.5.9
drupal/drupal
Packagist
8.6.0 up to 8.6.6
8.6.6
drupal7
Debian:8
before 7.32-1+deb8u15, plus listed versions
7.32-1+deb8u107.32-1+deb8u117.32-1+deb8u127.32-1+deb8u137.32-1+deb8u14
Show 9 moreShow less
7.32-1+deb8u37.32-1+deb8u47.32-1+deb8u4~bpo70+17.32-1+deb8u57.32-1+deb8u5~bpo70+17.32-1+deb8u67.32-1+deb8u77.32-1+deb8u87.32-1+deb8u9
7.32-1+deb8u15
drupal/core
Packagist
8.0.0 up to 8.5.9, 8.6.0 up to 8.6.6, plus listed versions
8.0.18.0.28.0.38.0.48.0.5
Show 45 moreShow less
8.0.68.1.08.1.0-beta18.1.0-beta28.1.0-rc18.1.18.1.108.1.28.1.38.1.48.1.58.1.68.1.78.1.88.1.98.2.08.2.0-beta18.2.0-beta28.2.0-beta38.2.0-rc18.2.0-rc28.2.18.2.28.2.38.2.48.2.58.2.68.2.78.2.88.3.08.3.0-alpha18.3.0-beta18.3.0-rc18.3.0-rc28.3.18.3.28.3.38.3.48.3.58.3.68.3.78.3.88.3.98.4.08.4.0-alpha1
8.5.98.6.6
drupal7
Debian:9
From an advisory covering 2 CVEs
before 7.52-2+deb9u6, plus listed versions
7.52-27.52-2+deb9u17.52-2+deb9u27.52-2+deb9u37.52-2+deb9u47.52-2+deb9u5
7.52-2+deb9u6
drupal/drupal
Packagist
8.0.0 up to 8.5.9, plus listed versions
8.0.18.0.28.0.38.0.48.0.5
Show 45 moreShow less
8.0.68.1.08.1.0-beta18.1.0-beta28.1.0-rc18.1.18.1.108.1.28.1.38.1.48.1.58.1.68.1.78.1.88.1.98.2.08.2.0-beta18.2.0-beta28.2.0-beta38.2.0-rc18.2.0-rc28.2.18.2.28.2.38.2.48.2.58.2.68.2.78.2.88.3.08.3.0-alpha18.3.0-beta18.3.0-rc18.3.0-rc28.3.18.3.28.3.38.3.48.3.58.3.68.3.78.3.88.3.98.4.08.4.0-alpha1
8.5.9
drupal/drupal
Packagist
8.6.0 up to 8.6.6, plus listed versions
8.6.18.6.28.6.38.6.48.6.5
8.6.6
drupal7
Ubuntu:Pro:14.04:LTS
All versions, plus listed versions
7.23-17.24-17.24-27.26-17.26-1ubuntu0.17.26-1ubuntu0.1+esm17.26-1ubuntu0.1+esm27.26-1ubuntu0.1+esm3
None known
drupal7
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
7.38-17.41-17.44-1ubuntu1~16.04.07.44-1ubuntu1~16.04.0+esm17.44-1ubuntu1~16.04.0+esm27.44-1ubuntu1~16.04.0+esm3
None known

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-6338 is a high vulnerability (CVSS 8.0) in Drupal, published January 16, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.12%, the 81st percentile. Fixed in drupal/drupal 7.62.0.

References

This page doesn't list everything

Left out here: 51 versions. The JSON record has them.

MoveEnter Open