CVE-2019-6804
Rundeck Community Edition vulnerable to Cross-site Scripting
An XSS issue was discovered on the Job Edit page in Rundeck Community Edition before 3.0.13, related to assets/javascripts/workflowStepEditorKO.js and views/execution/_wfitemEdit.gsp.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
An XSS issue was discovered on the Job Edit page in Rundeck Community Edition before 3.0.13, related to assets/javascripts/workflowStepEditorKO.js and views/execution/_wfitemEdit.gsp.
- Record
CVE-2019-6804- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
An XSS issue was discovered on the Job Edit page in Rundeck Community Edition before 3.0.13, related to assets/javascripts/workflowStepEditorKO.js and views/execution/_wfitemEdit.gsp.
- Record
CVE-2019-6804- Updated
- 2026-11-02
EUVDEUVD-2022-2264 No score
An XSS issue was discovered on the Job Edit page in Rundeck Community Edition before 3.0.13, related to assets/javascripts/workflowStepEditorKO.js and views/execution/_wfitemEdit.gsp.
- Record
EUVD-2022-2264- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-4262-wr7p-gpcj
6.1
Rundeck Community Edition vulnerable to Cross-site Scripting
An XSS issue was discovered on the Job Edit page in Rundeck Community Edition before 3.0.13, related to assets/javascripts/workflowStepEditorKO.js and views/execution/_wfitemEdit.gsp.
- Record
GHSA-4262-wr7p-gpcj- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
6.1
An XSS issue was discovered on the Job Edit page in Rundeck Community Edition before 3.0.13, related to assets/javascripts/workflowStepEditorKO.js and views/execution/_wfitemEdit.gsp.
- Record
CVE-2019-6804- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-4262-wr7p-gpcj
6.1
Rundeck Community Edition vulnerable to Cross-site Scripting
An XSS issue was discovered on the Job Edit page in Rundeck Community Edition before 3.0.13, related to assets/javascripts/workflowStepEditorKO.js and views/execution/_wfitemEdit.gsp.
- Record
GHSA-4262-wr7p-gpcj- CVSS 3.0
- 6.1 Medium
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.rundeck:rundeckMaven |
before 3.0.13 | 3.0.13 |
org.rundeck:rundeckMaven |
before 3.0.13, plus listed versions 3.0.0-201807273.0.0-alpha13.0.1-201808033.0.10-201812203.0.11-20181221 Show 7 moreShow less3.0.12-201901143.0.2-201808033.0.2-201808173.0.5-201808283.0.7-201810083.0.8-201810293.0.9-20181127 |
3.0.13 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| Exploit-DB | Rundeck Community Edition < 3.0.13 - Persistent Cross-Site Scripting | 2019-01-28 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, Exploit-DB, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-6804 is a medium vulnerability (CVSS 6.1) in Pagerduty Rundeck, published January 25, 2019. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 5.32%, the 92nd percentile. Fixed in org.rundeck:rundeck 3.0.13.