CVE-2019-6970
Moodle SSRF Vulnerability
Moodle 3.5.x before 3.5.4 allows SSRF.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.5
Moodle 3.5.x before 3.5.4 allows SSRF.
- Record
CVE-2019-6970- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.0 Medium
AV:N/AC:M/Au:S/C:P/I:P/A:P - Weakness
- CWE-918
- Updated
- 2026-11-02
CVE List No score
Moodle 3.5.x before 3.5.4 allows SSRF.
- Record
CVE-2019-6970- Updated
- 2026-11-02
EUVDEUVD-2022-5376
0.0
Moodle 3.5.x before 3.5.4 allows SSRF.
- Record
EUVD-2022-5376- CVSS
- 0.0 None
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-vjxx-54vw-q59f
7.5
Moodle SSRF Vulnerability
The edit_blog.php script allows a registered user to add external RSS feed resources. It was identified that this feature could be abused to be used as a SSRF attack vector by adding a malicious URL/TCP PORT in order to target internal network or an internet hosted server, bypassing firewall rules, IP filtering and more.
This kind of vulnerability is then called “blind” because of no response available on Moodle web site, enforcing attacker to exploit it using a “time based” approach.
- Record
GHSA-vjxx-54vw-q59f- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918
- Updated
- 2026-11-02
OSV
7.5
Moodle 3.5.x before 3.5.4 allows SSRF.
- Record
CVE-2019-6970- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVGHSA-vjxx-54vw-q59f
7.5
Moodle SSRF Vulnerability
The edit_blog.php script allows a registered user to add external RSS feed resources. It was identified that this feature could be abused to be used as a SSRF attack vector by adding a malicious URL/TCP PORT in order to target internal network or an internet hosted server, bypassing firewall rules, IP filtering and more.
This kind of vulnerability is then called “blind” because of no response available on Moodle web site, enforcing attacker to exploit it using a “time based” approach.
- Record
GHSA-vjxx-54vw-q59f- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-918
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-6970
7.5
Moodle 3.5.x before 3.5.4 allows SSRF.
- Record
UBUNTU-CVE-2019-6970- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
3.5.0 up to 3.5.4 | 3.5.4 |
moodle/moodlePackagist |
3.5.0 up to 3.5.4, plus listed versions v3.5.0v3.5.1v3.5.2v3.5.3 |
3.5.4 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-6970 is a high vulnerability (CVSS 7.5) in Moodle, published March 18, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.42%, the 72nd percentile. Fixed in moodle/moodle 3.5.4.
References
excellium-services.com/cert-xlm-advisory/cve-2019-6970
excellium-services.com/cert-xlm-advisory
cds.thalesgroup.com/en/tcs-cert/CVE-2019-6970
nvd.nist.gov/vuln/detail/CVE-2019-6970
github.com/advisories/GHSA-vjxx-54vw-q59f
github.com/moodle/moodle
ubuntu.com/security/CVE-2019-6970
cve.org/CVERecord?id=CVE-2019-6970