Every CVE Search/ Get API key

CVE-2019-6991

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the...

9.8 CriticalFix available

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the zmu binary in ZoneMinder through 1.32.3, allowing an unauthenticated attacker to execute code via a long username.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

3.31%Up 2.2 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 9.8

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the zmu binary in ZoneMinder through 1.32.3, allowing an unauthenticated attacker to execute code via a long username.

Record
CVE-2019-6991
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-787
Updated
2026-11-02
CVE List No score

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the zmu binary in ZoneMinder through 1.32.3, allowing an unauthenticated attacker to execute code via a long username.

Record
CVE-2019-6991
Updated
2026-11-02
EUVDEUVD-2019-16542 No score

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the zmu binary in ZoneMinder through 1.32.3, allowing an unauthenticated attacker to execute code via a long username.

Record
EUVD-2019-16542
Updated
2026-11-03
GitHub AdvisoriesGHSA-j63x-h9vw-pgh3 9.8

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the...

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the zmu binary in ZoneMinder through 1.32.3, allowing an unauthenticated attacker to execute code via a long username.

Record
GHSA-j63x-h9vw-pgh3
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-787
Updated
2026-11-02
OSVALPINE-CVE-2019-6991 9.8

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the zmu binary in ZoneMinder through 1.32.3, allowing an unauthenticated attacker to execute code via a long username.

Record
ALPINE-CVE-2019-6991
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 9.8

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the zmu binary in ZoneMinder through 1.32.3, allowing an unauthenticated attacker to execute code via a long username.

Record
CVE-2019-6991
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2019-6991 9.8

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the zmu binary in ZoneMinder through 1.32.3, allowing an unauthenticated attacker to execute code via a long username.

Record
DEBIAN-CVE-2019-6991
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2019-6991 9.8

A classic Stack-based buffer overflow exists in the zmLoadUser() function in zm_user.cpp of the zmu binary in ZoneMinder through 1.32.3, allowing an unauthenticated attacker to execute code via a long username.

Record
UBUNTU-CVE-2019-6991
CVSS 3.0
9.8 CriticalCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUSN-5889-1 No score

zoneminder vulnerabilities

It was discovered that ZoneMinder was not properly sanitizing URL parameters for certain views. An attacker could possibly use this issue to perform a cross-site scripting (XSS) attack. This issue was only fixed in Ubuntu 16.04 ESM. (CVE-2019-6777)

It was discovered that ZoneMinder was not properly sanitizing stored user input later printed to the user in certain views. An attacker could possibly use this issue to perform a cross-site scripting (XSS) attack. This issue was only fixed in Ubuntu 16.04 ESM. (CVE-2019-6990, CVE-2019-6992)

It was discovered that ZoneMinder was not properly limiting data size and not properly performing bound checks when processing username and password data, which could lead to a stack buffer overflow. An attacker could possibly use this issue to bypass authentication, cause a denial of service or execute arbitrary code. This issue was only fixed in Ubuntu 16.04 ESM. (CVE-2019-6991)

It was discovered that ZoneMinder was not properly defining and filtering data that was appended to the webroot URL of a view. An attacker could possibly use this issue to perform cross-site scripting (XSS) attacks. This issue was only fixed in Ubuntu 16.04 ESM and Ubuntu 20.04 ESM. (CVE-2019-7325, CVE-2019-7329)

It was discovered that ZoneMinder was not properly sanitizing stored user input later printed to the user in certain views. An attacker could possibly use this issue to perform a cross-site scripting (XSS) attack. This issue was only fixed in Ubuntu 20.04 ESM. (CVE-2019-7326)

It was discovered that ZoneMinder was not properly sanitizing URL parameters for certain views. An attacker could possibly use this issue to perform a cross-site scripting (XSS) attack. This issue was only fixed in Ubuntu 20.04 ESM. (CVE-2019-7327, CVE-2019-7328, CVE-2019-7330, CVE-2019-7332)

It was discovered that ZoneMinder was not properly sanitizing user input in the monitor editing view. An attacker could possibly use this issue to perform a cross-site scripting (XSS) attack. This issue was only fixed in Ubuntu 16.04 ESM and Ubuntu 20.04 ESM. (CVE-2019-7331)

It was discovered that ZoneMinder was not properly sanitizing data related to file paths in a system. An attacker could possibly use this issue to execute arbitrary code. (CVE-2022-29806)

Record
USN-5889-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zoneminder
Alpine:v3.15
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.16
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.17
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.18
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.19
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.20
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.21
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.22
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.23
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.24
before 1.36.7-r0
1.36.7-r0
Show 6 moreShow less
Affected packages
PackageAffectedFixed
zoneminder
Debian:12
before 1.32.3-2
1.32.3-2
zoneminder
Debian:13
before 1.32.3-2
1.32.3-2
zoneminder
Debian:14
before 1.32.3-2
1.32.3-2
zoneminder
Ubuntu:Pro:16.04:LTS
before 1.29.0+dfsg-1ubuntu2+esm1, plus listed versions
1.28.1-81.29.0+dfsg-11.29.0+dfsg-1ubuntu11.29.0+dfsg-1ubuntu2
1.29.0+dfsg-1ubuntu2+esm1
zoneminder
Ubuntu:Pro:20.04:LTS
before 1.32.3-2ubuntu2+esm1, plus listed versions
1.32.3-2build11.32.3-2ubuntu11.32.3-2ubuntu2
1.32.3-2ubuntu2+esm1
zoneminder
Ubuntu:Pro:22.04:LTS
before 1.36.12+dfsg1-1ubuntu0.1~esm1, plus listed versions
1.36.7+dfsg1-11.36.10+dfsg1-11.36.11+dfsg1-11.36.12+dfsg1-1
1.36.12+dfsg1-1ubuntu0.1~esm1

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-6991 is a critical vulnerability (CVSS 9.8) in Zoneminder, published January 28, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 3.31%, the 88th percentile. Fixed in zoneminder 1.36.7-r0.

References

Show 15 moreShow less
MoveEnter Open