Every CVE Search/ Get API key

CVE-2019-7342

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to...

6.1 MediumFix available

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to execute HTML or JavaScript code via a vulnerable 'filter[AutoExecuteCmd]' parameter value in the view filter (filter.php) because proper filtration is omitted.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.99%Up 0.6 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 6.1

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to execute HTML or JavaScript code via a vulnerable 'filter[AutoExecuteCmd]' parameter value in the view filter (filter.php) because proper filtration is omitted.

Record
CVE-2019-7342
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
CVE List No score

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to execute HTML or JavaScript code via a vulnerable 'filter[AutoExecuteCmd]' parameter value in the view filter (filter.php) because proper filtration is omitted.

Record
CVE-2019-7342
Updated
2026-11-02
EUVDEUVD-2019-16885 No score

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to execute HTML or JavaScript code via a vulnerable 'filter[AutoExecuteCmd]' parameter value in the view filter (filter.php) because proper filtration is omitted.

Record
EUVD-2019-16885
Updated
2026-11-03
GitHub AdvisoriesGHSA-x6vr-c2q5-qrfg 6.1

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to...

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to execute HTML or JavaScript code via a vulnerable 'filter[AutoExecuteCmd]' parameter value in the view filter (filter.php) because proper filtration is omitted.

Record
GHSA-x6vr-c2q5-qrfg
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVALPINE-CVE-2019-7342 6.1

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to execute HTML or JavaScript code via a vulnerable 'filter[AutoExecuteCmd]' parameter value in the view filter (filter.php) because proper filtration is omitted.

Record
ALPINE-CVE-2019-7342
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-03
OSV 6.1

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to execute HTML or JavaScript code via a vulnerable 'filter[AutoExecuteCmd]' parameter value in the view filter (filter.php) because proper filtration is omitted.

Record
CVE-2019-7342
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVDEBIAN-CVE-2019-7342 6.1

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to execute HTML or JavaScript code via a vulnerable 'filter[AutoExecuteCmd]' parameter value in the view filter (filter.php) because proper filtration is omitted.

Record
DEBIAN-CVE-2019-7342
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2019-7342 6.1

POST - Cross Site Scripting (XSS) exists in ZoneMinder through 1.32.3, allowing an attacker to execute HTML or JavaScript code via a vulnerable 'filter[AutoExecuteCmd]' parameter value in the view filter (filter.php) because proper filtration is omitted.

Record
UBUNTU-CVE-2019-7342
CVSS 3.0
6.1 MediumCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zoneminder
Alpine:v3.15
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.16
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.17
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.18
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.19
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.20
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.21
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.22
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.23
before 1.36.7-r0
1.36.7-r0
zoneminder
Alpine:v3.24
before 1.36.7-r0
1.36.7-r0
Show 9 moreShow less
Affected packages
PackageAffectedFixed
zoneminder
Debian:12
before 1.34.6-1
1.34.6-1
zoneminder
Debian:13
before 1.34.6-1
1.34.6-1
zoneminder
Debian:14
before 1.34.6-1
1.34.6-1
zoneminder
Ubuntu:Pro:20.04:LTS
All versions, plus listed versions
1.32.3-2build11.32.3-2ubuntu11.32.3-2ubuntu21.32.3-2ubuntu2+esm1
None known
zoneminder
Ubuntu:Pro:22.04:LTS
All versions, plus listed versions
1.36.7+dfsg1-11.36.10+dfsg1-11.36.11+dfsg1-11.36.12+dfsg1-11.36.12+dfsg1-1ubuntu0.1~esm1
None known
zoneminder
Ubuntu:24.04:LTS
All versions, plus listed versions
1.36.33+dfsg1-1build11.36.33+dfsg1-1build21.36.33+dfsg1-1build31.36.33+dfsg1-1build4
None known
zoneminder
Ubuntu:25.10
All versions, plus listed versions
1.36.35+dfsg1-1
None known
zoneminder
Ubuntu:26.10
All versions, plus listed versions
1.36.37+dfsg1-1
None known
zoneminder
Ubuntu:26.04:LTS
All versions, plus listed versions
1.36.35+dfsg1-11.36.37+dfsg1-1
None known

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2019-7342 is a medium vulnerability (CVSS 6.1) in Zoneminder, published February 4, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.99%, the 62nd percentile. Fixed in zoneminder 1.36.7-r0.

References

MoveEnter Open