CVE-2019-7659
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service ...
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.
- Record
CVE-2019-7659- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-787
- Updated
- 2026-11-02
CVE List No score
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.
- Record
CVE-2019-7659- Updated
- 2026-11-02
EUVDEUVD-2019-17191 No score
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.
- Record
EUVD-2019-17191- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g59f-fwhq-fr4r
8.1
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service ...
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.
- Record
GHSA-g59f-fwhq-fr4r- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-787
- Updated
- 2026-11-02
OSV
8.1
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.
- Record
CVE-2019-7659- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-7659
8.1
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.
- Record
DEBIAN-CVE-2019-7659- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-7659
8.1
Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.
- Record
UBUNTU-CVE-2019-7659- CVSS 3.0
- 8.1 High
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gsoapDebian:12 |
before 2.8.75-1 | 2.8.75-1 |
gsoapDebian:13 |
before 2.8.75-1 | 2.8.75-1 |
gsoapDebian:14 |
before 2.8.75-1 | 2.8.75-1 |
r-other-x4rDebian:12 |
before 1.0.1+git20150806.c6bd9bd-2 | 1.0.1+git20150806.c6bd9bd-2 |
r-other-x4rDebian:13 |
before 1.0.1+git20150806.c6bd9bd-2 | 1.0.1+git20150806.c6bd9bd-2 |
r-other-x4rDebian:14 |
before 1.0.1+git20150806.c6bd9bd-2 | 1.0.1+git20150806.c6bd9bd-2 |
gsoapDebian:8 |
before 2.8.17-1+deb8u2, plus listed versions 2.8.17-12.8.17-1+deb8u1 |
2.8.17-1+deb8u2 |
gsoapUbuntu:16.04:LTS |
All versions, plus listed versions 2.8.22-12.8.22-22.8.28-1 |
None known |
gsoapUbuntu:18.04:LTS |
All versions, plus listed versions 2.8.49-12.8.60-2build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-7659 is a high vulnerability (CVSS 8.1) in Genivia Gsoap, published February 9, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.99%, the 80th percentile. Fixed in gsoap 2.8.75-1.
References
lists.debian.org/debian-lts-announce/2019/02/msg00027.html
genivia.com/advisory.html
outpost24.com/blog/gsoap-vulnerability-identified
nvd.nist.gov/vuln/detail/CVE-2019-7659
github.com/advisories/GHSA-g59f-fwhq-fr4r
security-tracker.debian.org/tracker/CVE-2019-7659
ubuntu.com/security/CVE-2019-7659
cve.org/CVERecord?id=CVE-2019-7659