Every CVE Search/ Get API key

CVE-2019-7845

Adobe Flash Player versions 32.0.0.192 and earlier, 32.0.0.192 and earlier, and 32.0.0.192 and...

8.8 HighFix available

CVE-2019-7845 is a high vulnerability (CVSS 8.8) in Adobe Flash Player, published June 12, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 5.50%, the 92nd percentile. Fixed in flash-player-plugin 32.0.0.207-1.mga6.nonfree.

Adobe Flash Player versions 32.0.0.192 and earlier, 32.0.0.192 and earlier, and 32.0.0.192 and earlier have an use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

5.50%Down 0.9 points since Apr 14, 2021
90%50%10%1%

What each source reports

NVD Score used 8.8

Adobe Flash Player versions 32.0.0.192 and earlier, 32.0.0.192 and earlier, and 32.0.0.192 and earlier have an use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

Record
CVE-2019-7845
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
CVSS 2.0
6.8 MediumAV:N/AC:M/Au:N/C:P/I:P/A:P
Weakness
CWE-416
Updated
2026-11-02
CVE List No score

Adobe Flash Player versions 32.0.0.192 and earlier, 32.0.0.192 and earlier, and 32.0.0.192 and earlier have an use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

Record
CVE-2019-7845
Updated
2026-11-02
EUVDEUVD-2019-17373 No score

Adobe Flash Player versions 32.0.0.192 and earlier, 32.0.0.192 and earlier, and 32.0.0.192 and earlier have an use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

Record
EUVD-2019-17373
Updated
2026-11-03
GitHub AdvisoriesGHSA-284f-xx97-3544 8.8

Adobe Flash Player versions 32.0.0.192 and earlier, 32.0.0.192 and earlier, and 32.0.0.192 and...

Adobe Flash Player versions 32.0.0.192 and earlier, 32.0.0.192 and earlier, and 32.0.0.192 and earlier have an use after free vulnerability. Successful exploitation could lead to arbitrary code execution.

Record
GHSA-284f-xx97-3544
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weakness
CWE-416
Updated
2026-11-02
OSVRHSA-2019:1476 8.8

Red Hat Security Advisory: flash-plugin security update

Record
RHSA-2019:1476
CVSS 3.0
8.8 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVMGASA-2019-0192 No score

Updated flash-player-plugin packages fix security vulnerability

Updated flash-player-plugin package fixes a security vulnerability:

A use after free that leads to arbitrary code execution. (CVE-2019-7845)

Record
MGASA-2019-0192
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
flash-player-plugin
Mageia:6
before 32.0.0.207-1.mga6.nonfree
32.0.0.207-1.mga6.nonfree
flash-plugin
Red Hat:rhel_extras:6
before 0:32.0.0.207-1.el6_10
0:32.0.0.207-1.el6_10

History

History
WhenChangedSources
2026-11-03aliasesEUVD
2026-11-02createdCVE List, GitHub Advisories, NVD, OSV

References

Show 10 moreShow less
MoveEnter Open