CVE-2019-8123
Magento 2 Community Edition Insufficient Logging
An insufficient logging and monitoring vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. The logging feature required for effective monitoring did not contain sufficent data to effectively track configuration changes.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.3
An insufficient logging and monitoring vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. The logging feature required for effective monitoring did not contain sufficent data to effectively track configuration changes.
- Record
CVE-2019-8123- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Updated
- 2026-11-02
CVE List No score
An insufficient logging and monitoring vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. The logging feature required for effective monitoring did not contain sufficent data to effectively track configuration changes.
- Record
CVE-2019-8123- Updated
- 2026-11-02
EUVDEUVD-2022-3814 No score
An insufficient logging and monitoring vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. The logging feature required for effective monitoring did not contain sufficent data to effectively track configuration changes.
- Record
EUVD-2022-3814- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-fp5m-4mqh-849p
5.3
Magento 2 Community Edition Insufficient Logging
An insufficient logging and monitoring vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. The logging feature required for effective monitoring did not contain sufficent data to effectively track configuration changes. As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
- Record
GHSA-fp5m-4mqh-849p- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-778
- Updated
- 2026-11-02
OSV
5.3
An insufficient logging and monitoring vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. The logging feature required for effective monitoring did not contain sufficent data to effectively track configuration changes.
- Record
CVE-2019-8123- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-fp5m-4mqh-849p
5.3
Magento 2 Community Edition Insufficient Logging
An insufficient logging and monitoring vulnerability exists in Magento 1 prior to 1.9.4.3 and 1.14.4.3, Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. The logging feature required for effective monitoring did not contain sufficent data to effectively track configuration changes. As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.
- Record
GHSA-fp5m-4mqh-849p- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-778
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
magento/community-editionPackagist |
2.1.0 up to 2.1.19 | 2.1.19 |
magento/community-editionPackagist |
2.2.0 up to 2.2.10 | 2.2.10 |
magento/community-editionPackagist |
2.3.0 up to 2.3.3 | 2.3.3 |
magento/community-editionPackagist |
2.1.0 up to 2.1.19, plus listed versions 2.1.12.1.102.1.112.1.122.1.13 Show 13 moreShow less2.1.142.1.152.1.162.1.172.1.182.1.22.1.32.1.42.1.52.1.62.1.72.1.82.1.9 |
2.1.19 |
magento/community-editionPackagist |
2.2.0 up to 2.2.10, plus listed versions 2.2.12.2.22.2.32.2.42.2.5 Show 4 moreShow less2.2.62.2.72.2.82.2.9 |
2.2.10 |
magento/community-editionPackagist |
2.3.0 up to 2.3.3, plus listed versions 2.3.12.3.22.3.2-p2 |
2.3.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-8123 is a medium vulnerability (CVSS 5.3) in Magento, published November 5, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.81%, the 57th percentile. Fixed in magento/community-edition 2.1.19.
References
magento.com/security/patches/supee-11219
nvd.nist.gov/vuln/detail/CVE-2019-8123
web.archive.org/web/20211209030216/https://magento.com/security/patches/supee-11219
github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ce/CVE-2019-8123.yaml
github.com/FriendsOfPHP/security-advisories/blob/master/magento/magento1ee/CVE-2019-8123.yaml
github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-8123.yaml
magento.com/security/patches/magento-2.3.3-and-2.2.10-security-update
github.com/advisories/GHSA-fp5m-4mqh-849p
github.com/magento/magento2