CVE-2019-9187
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190226 allows SSRF via the...
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the aggregate plugin. The impact also includes reading local files via file: URIs.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the aggregate plugin. The impact also includes reading local files via file: URIs.
- Record
CVE-2019-9187- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-918
- Updated
- 2026-11-02
CVE List No score
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the aggregate plugin. The impact also includes reading local files via file: URIs.
- Record
CVE-2019-9187- Updated
- 2026-11-02
EUVDEUVD-2019-18564 No score
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the aggregate plugin. The impact also includes reading local files via file: URIs.
- Record
EUVD-2019-18564- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-3h26-q9xc-fjff
7.5
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190226 allows SSRF via the...
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190226 allows SSRF via the aggregate plugin. The impact also includes reading local files via file: URIs.
- Record
GHSA-3h26-q9xc-fjff- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-918
- Updated
- 2026-11-02
OSV
7.5
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the aggregate plugin. The impact also includes reading local files via file: URIs.
- Record
CVE-2019-9187- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVDEBIAN-CVE-2019-9187
7.5
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the aggregate plugin. The impact also includes reading local files via file: URIs.
- Record
DEBIAN-CVE-2019-9187- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVUBUNTU-CVE-2019-9187
7.5
ikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190228 allows SSRF via the aggregate plugin. The impact also includes reading local files via file: URIs.
- Record
UBUNTU-CVE-2019-9187- CVSS 3.0
- 7.5 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVMGASA-2019-0113 No score
Updated ikiwiki packages fix security vulnerability
Several security issues identified in ikiwiki fixed by updating to version 3.20190228. See references for details
- Record
MGASA-2019-0113- Updated
- 2026-11-02
OSVopenSUSE-SU-2024:10860-1 No score
ikiwiki-3.20200202.3-2.7 on GA media
These are all security issues fixed in the ikiwiki-3.20200202.3-2.7 package on the GA media of openSUSE Tumbleweed.
- Record
openSUSE-SU-2024:10860-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
ikiwikiDebian:12 |
before 3.20190228-1 | 3.20190228-1 |
ikiwikiDebian:13 |
before 3.20190228-1 | 3.20190228-1 |
ikiwikiDebian:14 |
before 3.20190228-1 | 3.20190228-1 |
ikiwikiDebian:8 |
before 3.20141016.4+deb8u1, plus listed versions 3.20141016.23.20141016.33.20141016.4 |
3.20141016.4+deb8u1 |
ikiwikiDebian:9 |
before 3.20170111.1, plus listed versions 3.20170111 |
3.20170111.1 |
ikiwikiMageia:6 From an advisory covering 6 CVEs |
before 3.20190228-1.1.mga6 | 3.20190228-1.1.mga6 |
ikiwikiUbuntu:16.04:LTS |
All versions, plus listed versions 3.201506143.20160121 |
None known |
ikiwikiUbuntu:18.04:LTS |
All versions, plus listed versions 3.201706223.201710013.20180105-13.20180228-1 |
None known |
ikiwikiopenSUSE:Tumbleweed From an advisory covering 14 CVEs |
before 3.20200202.3-2.7 | 3.20200202.3-2.7 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2019-9187 is a high vulnerability (CVSS 7.5) in Ikiwiki, published February 28, 2019. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.70%, the 77th percentile. Fixed in ikiwiki 3.20190228-1.
References
lists.debian.org/debian-lts-announce/2019/03/msg00018.html
ikiwiki.info/news
ikiwiki.info/news/version_3.20190228
nvd.nist.gov/vuln/detail/CVE-2019-9187
github.com/advisories/GHSA-3h26-q9xc-fjff
security-tracker.debian.org/tracker/CVE-2019-9187
Show 28 moreShow less
advisories.mageia.org/MGASA-2019-0113.html
bugs.mageia.org/show_bug.cgi?id=24453
openwall.com/lists/oss-security/2019/02/28/1
openwall.com/lists/oss-security/2017/01/12/2
openwall.com/lists/oss-security/2016/05/06/8
openwall.com/lists/oss-security/2016/05/06/9
debian.org/security/2019/dsa-4399
ubuntu.com/security/CVE-2019-9187
ikiwiki.info/security
source.ikiwiki.branchable.com?p=source.git;a=commitdiff;h=e7b0d4a
source.ikiwiki.branchable.com?p=source.git;a=commitdiff;h=67543ce
source.ikiwiki.branchable.com?p=source.git;a=commitdiff;h=d283e4c
source.ikiwiki.branchable.com?p=source.git;a=commitdiff;h=9a275b2
cve.org/CVERecord?id=CVE-2019-9187
suse.com/security/cve/CVE-2008-0169
suse.com/security/cve/CVE-2009-2944
suse.com/security/cve/CVE-2011-0428
suse.com/security/cve/CVE-2011-1401
suse.com/security/cve/CVE-2012-0220
suse.com/security/cve/CVE-2014-1572
suse.com/security/cve/CVE-2016-10026
suse.com/security/cve/CVE-2016-1238
suse.com/security/cve/CVE-2016-3714
suse.com/security/cve/CVE-2016-4561
suse.com/security/cve/CVE-2016-9645
suse.com/security/cve/CVE-2016-9646
suse.com/security/cve/CVE-2017-0356
suse.com/security/cve/CVE-2019-9187