Every CVE Search/ Get API key

CVE-2020-10699

A flaw was found in Linux, in targetcli-fb versions 2.1.50 and 2.1.51 where the socket used by...

7.8 HighFix available

A flaw was found in Linux, in targetcli-fb versions 2.1.50 and 2.1.51 where the socket used by targetclid was world-writable. If a system enables the targetclid socket, a local attacker can use this flaw to modify the iSCSI configuration and escalate their privileges to root.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.34%Down 0.1 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 7.8

A flaw was found in Linux, in targetcli-fb versions 2.1.50 and 2.1.51 where the socket used by targetclid was world-writable. If a system enables the targetclid socket, a local attacker can use this flaw to modify the iSCSI configuration and escalate their privileges to root.

Record
CVE-2020-10699
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-732
Updated
2026-11-02
EUVDEUVD-2020-3130 7.8

A flaw was found in Linux, in targetcli-fb versions 2.1.50 and 2.1.51 where the socket used by targetclid was world-writable. If a system enables the targetclid socket, a local attacker can use this flaw to modify the iSCSI configuration and escalate their privileges to root.

Record
EUVD-2020-3130
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-pvmm-475g-fx2h 7.8

A flaw was found in Linux, in targetcli-fb versions 2.1.50 and 2.1.51 where the socket used by...

A flaw was found in Linux, in targetcli-fb versions 2.1.50 and 2.1.51 where the socket used by targetclid was world-writable. If a system enables the targetclid socket, a local attacker can use this flaw to modify the iSCSI configuration and escalate their privileges to root.

Record
GHSA-pvmm-475g-fx2h
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-732
Updated
2026-11-02
NVD 7.8

A flaw was found in Linux, in targetcli-fb versions 2.1.50 and 2.1.51 where the socket used by targetclid was world-writable. If a system enables the targetclid socket, a local attacker can use this flaw to modify the iSCSI configuration and escalate their privileges to root.

Record
CVE-2020-10699
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.2 HighAV:L/AC:L/Au:N/C:C/I:C/A:C
Weakness
CWE-732
Updated
2026-11-02
OSVALPINE-CVE-2020-10699 7.8

A flaw was found in Linux, in targetcli-fb versions 2.1.50 and 2.1.51 where the socket used by targetclid was world-writable. If a system enables the targetclid socket, a local attacker can use this flaw to modify the iSCSI configuration and escalate their privileges to root.

Record
ALPINE-CVE-2020-10699
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-03
OSV 7.8

A flaw was found in Linux, in targetcli-fb versions 2.1.50 and 2.1.51 where the socket used by targetclid was world-writable. If a system enables the targetclid socket, a local attacker can use this flaw to modify the iSCSI configuration and escalate their privileges to root.

Record
CVE-2020-10699
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
Show 4 moreShow less
OSVRHSA-2020:1933 7.8

Red Hat Security Advisory: targetcli security update

Record
RHSA-2020:1933
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-10699 7.8

A flaw was found in Linux, in targetcli-fb versions 2.1.50 and 2.1.51 where the socket used by targetclid was world-writable. If a system enables the targetclid socket, a local attacker can use this flaw to modify the iSCSI configuration and escalate their privileges to root.

Record
UBUNTU-CVE-2020-10699
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2024:11423-1 No score

python36-targetcli-fb-2.1.54-1.2 on GA media

These are all security issues fixed in the python36-targetcli-fb-2.1.54-1.2 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11423-1
Updated
2026-11-02
OSVUSN-4871-1 No score

targetcli-fb vulnerabilities

It was discovered that targetcli-fb did not properly manage socket permissions. A local attacker could use this issue to modify the iSCSI configuration resulting in a denial of service, obtain sensitive information or execute arbitrary code. (CVE-2020-10699)

It was discovered that targetcli-fb did not properly manage permissions for /etc/target and underneath backup directory/files. An attacker could use this issue to access sensitive information. (CVE-2020-13867)

Record
USN-4871-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
targetcli
Alpine:v3.13
before 2.1.53-r0
2.1.53-r0
targetcli
Alpine:v3.14
before 2.1.53-r0
2.1.53-r0
targetcli
Alpine:v3.15
before 2.1.53-r0
2.1.53-r0
targetcli
Alpine:v3.16
before 2.1.53-r0
2.1.53-r0
targetcli
Alpine:v3.17
before 2.1.53-r0
2.1.53-r0
targetcli
Alpine:v3.18
before 2.1.53-r0
2.1.53-r0
targetcli
Alpine:v3.19
before 2.1.53-r0
2.1.53-r0
targetcli
Alpine:v3.20
before 2.1.53-r0
2.1.53-r0
targetcli
Alpine:v3.21
before 2.1.53-r0
2.1.53-r0
targetcli
Alpine:v3.22
before 2.1.53-r0
2.1.53-r0
Show 6 moreShow less
Affected packages
PackageAffectedFixed
targetcli
Alpine:v3.23
before 2.1.53-r0
2.1.53-r0
targetcli
Alpine:v3.24
before 2.1.53-r0
2.1.53-r0
targetcli
Red Hat:enterprise_linux:8::appstream
before 0:2.1.51-4.el8_2
0:2.1.51-4.el8_2
targetcli-fb
Ubuntu:Pro:20.04:LTS
before 1:2.1.51-0ubuntu1+esm1, plus listed versions
2.1.fb49-11:2.1.51-0ubuntu1
1:2.1.51-0ubuntu1+esm1
targetcli-fb
Ubuntu:Pro:20.04:LTS
From an advisory covering 2 CVEs
before 1:2.1.51-0ubuntu1+esm1, plus listed versions
2.1.fb49-11:2.1.51-0ubuntu1
1:2.1.51-0ubuntu1+esm1
targetcli
openSUSE:Tumbleweed
From an advisory covering 2 CVEs
before 2.1.54-1.2
2.1.54-1.2

History

History
RecordedChangedSources
affected, facts
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-10699 is a high vulnerability (CVSS 7.8) in Datera, Inc Targetcli, published April 15, 2020. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.34%, the 26th percentile. Fixed in targetcli 2.1.53-r0.

References

Show 11 moreShow less
MoveEnter Open