Every CVE Search/ Get API key

CVE-2020-11800

Zabbix Server 2.2.x and 3.0.x before 3.0.31, and 3.2 allows remote attackers to execute arbitrary...

9.0 CriticalPublic exploitFix available

Zabbix Server 2.2.x and 3.0.x before 3.0.31, and 3.2 allows remote attackers to execute arbitrary code.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

9.19%Up 6.5 points since Apr 14, 2021
90%50%10%1%

What each source reports

CVE List Score used 9.0

Zabbix Server 2.2.x and 3.0.x before 3.0.31, and 3.2 allows remote attackers to execute arbitrary code.

Record
CVE-2020-11800
CVSS 3.0
9.0 CriticalCVSS:3.0/AC:H/AV:N/A:H/C:H/I:H/PR:N/S:C/UI:N
Updated
2026-11-02
EUVDEUVD-2020-4142 9.0

Zabbix Server 2.2.x and 3.0.x before 3.0.31, and 3.2 allows remote attackers to execute arbitrary code.

Record
EUVD-2020-4142
CVSS 3.0
9.0 CriticalCVSS:3.0/AC:H/AV:N/A:H/C:H/I:H/PR:N/S:C/UI:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-cv5w-5v87-ffvf No score

Zabbix Server 2.2.x and 3.0.x before 3.0.31, and 3.2 allows remote attackers to execute arbitrary...

Zabbix Server 2.2.x and 3.0.x before 3.0.31, and 3.2 allows remote attackers to execute arbitrary code.

Record
GHSA-cv5w-5v87-ffvf
Updated
2026-11-02
NVD 9.8

Zabbix Server 2.2.x and 3.0.x before 3.0.31, and 3.2 allows remote attackers to execute arbitrary code.

Record
CVE-2020-11800
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
9.0 CriticalCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Updated
2026-11-02
OSV 9.8

Zabbix Server 2.2.x and 3.0.x before 3.0.31, and 3.2 allows remote attackers to execute arbitrary code.

Record
CVE-2020-11800
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2020-11800 9.8

Zabbix Server 2.2.x and 3.0.x before 3.0.31, and 3.2 allows remote attackers to execute arbitrary code.

Record
DEBIAN-CVE-2020-11800
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2020-11800 9.8

Zabbix Server 2.2.x and 3.0.x before 3.0.31, and 3.2 allows remote attackers to execute arbitrary code.

Record
UBUNTU-CVE-2020-11800
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
9.0 CriticalCVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
OSVopenSUSE-SU-2020:1604-1 No score

Security update for zabbix

This update for zabbix fixes the following issues:

Updated to version 3.0.31.

  • CVE-2020-15803: Fixed an XSS in the URL Widget (boo#1174253).
Record
openSUSE-SU-2020:1604-1
Updated
2026-11-02
OSVUSN-4767-1 No score

zabbix vulnerabilities

Fu Chuang discovered that Zabbix did not properly parse IPs. A remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM and Ubuntu 18.04 ESM. (CVE-2020-11800)

It was discovered that Zabbix incorrectly handled certain requests. A remote attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 14.04 ESM and Ubuntu 16.04 ESM. (CVE-2017-2824, CVE-2017-2825)

It was discovered that Zabbix incorrectly handled certain XML files. A remote attacker could possibly use this issue to read arbitrary files or potentially execute arbitrary code. This issue only affected Ubuntu 14.04 ESM. (CVE-2014-3005)

It was discovered that Zabbix incorrectly handled certain inputs. A remote attacker could possibly use this issue to execute arbitrary SQL commands. This issue only affected Ubuntu 14.04 ESM. (CVE-2016-10134, CVE-2016-4338)

It was discovered that Zabbix incorrectly handled the request parameter. A remote attacker could possibly use this issue to redirect requests to external links. This issue only affected Ubuntu 14.04 ESM and Ubuntu 18.04 ESM. (CVE-2016-10742)

It was discovered that Zabbix incorrectly handled failed login attempts. A remote attacker could possibly use this issue to enumerate users. (CVE-2019-15132)

It was discovered that Zabbix did not properly validate input. A remote attacker could exploit this to conduct cross-site scripting (XSS) attacks. This issue only affected Ubuntu 16.04 ESM, Ubuntu 18.04 ESM and Ubuntu 20.04 ESM. (CVE-2020-15803)

Record
USN-4767-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zabbix
Debian:12
before 1:4.0.0+dfsg-1
1:4.0.0+dfsg-1
zabbix
Debian:13
before 1:4.0.0+dfsg-1
1:4.0.0+dfsg-1
zabbix
Debian:14
before 1:4.0.0+dfsg-1
1:4.0.0+dfsg-1
zabbix
Debian:9
From an advisory covering 2 CVEs
before 1:3.0.31+dfsg-0+deb9u1, plus listed versions
1:3.0.12+dfsg-11:3.0.17+dfsg-11:3.0.17+dfsg-1~bpo9+11:3.0.7+dfsg-31:3.0.7+dfsg-3+deb9u1
1:3.0.31+dfsg-0+deb9u1
zabbix
Ubuntu:Pro:14.04:LTS
before 1:2.2.2+dfsg-1ubuntu1+esm3, plus listed versions
1:2.0.6+dfsg-1ubuntu21:2.2.0+dfsg-1ubuntu11:2.2.0+dfsg-6ubuntu11:2.2.1+dfsg-1ubuntu31:2.2.2+dfsg-1ubuntu11:2.2.2+dfsg-1ubuntu1+esm1
1:2.2.2+dfsg-1ubuntu1+esm3
zabbix
Ubuntu:Pro:16.04:LTS
before 1:2.4.7+dfsg-2ubuntu2.1+esm2, plus listed versions
1:2.4.6+dfsg-11:2.4.7+dfsg-11:2.4.7+dfsg-21:2.4.7+dfsg-2ubuntu21:2.4.7+dfsg-2ubuntu2.11:2.4.7+dfsg-2ubuntu2.1+esm1
1:2.4.7+dfsg-2ubuntu2.1+esm2
zabbix
Ubuntu:Pro:18.04:LTS
before 1:3.0.12+dfsg-1ubuntu0.1~esm2, plus listed versions
1:3.0.7+dfsg-31:3.0.12+dfsg-11:3.0.12+dfsg-1ubuntu0.1~esm1
1:3.0.12+dfsg-1ubuntu0.1~esm2
zabbix
Ubuntu:Pro:14.04:LTS
From an advisory covering 9 CVEs
before 1:2.2.2+dfsg-1ubuntu1+esm4, plus listed versions
1:2.0.6+dfsg-1ubuntu21:2.2.0+dfsg-1ubuntu11:2.2.0+dfsg-6ubuntu11:2.2.1+dfsg-1ubuntu31:2.2.2+dfsg-1ubuntu11:2.2.2+dfsg-1ubuntu1+esm11:2.2.2+dfsg-1ubuntu1+esm3
1:2.2.2+dfsg-1ubuntu1+esm4
zabbix
Ubuntu:Pro:16.04:LTS
From an advisory covering 9 CVEs
before 1:2.4.7+dfsg-2ubuntu2.1+esm3, plus listed versions
1:2.4.6+dfsg-11:2.4.7+dfsg-11:2.4.7+dfsg-21:2.4.7+dfsg-2ubuntu21:2.4.7+dfsg-2ubuntu2.11:2.4.7+dfsg-2ubuntu2.1+esm11:2.4.7+dfsg-2ubuntu2.1+esm2
1:2.4.7+dfsg-2ubuntu2.1+esm3
zabbix
Ubuntu:Pro:18.04:LTS
From an advisory covering 9 CVEs
before 1:3.0.12+dfsg-1ubuntu0.1~esm3, plus listed versions
1:3.0.7+dfsg-31:3.0.12+dfsg-11:3.0.12+dfsg-1ubuntu0.1~esm11:3.0.12+dfsg-1ubuntu0.1~esm2
1:3.0.12+dfsg-1ubuntu0.1~esm3
Show 5 moreShow less
Affected packages
PackageAffectedFixed
zabbix
Ubuntu:Pro:20.04:LTS
From an advisory covering 9 CVEs
before 1:4.0.17+dfsg-1ubuntu0.1~esm1, plus listed versions
1:4.0.4+dfsg-1build21:4.0.4+dfsg-1build31:4.0.11+dfsg-11:4.0.14+dfsg-11:4.0.15+dfsg-11:4.0.16+dfsg-11:4.0.16+dfsg-1build11:4.0.17+dfsg-1
1:4.0.17+dfsg-1ubuntu0.1~esm1
zabbix
SUSE:Package Hub 15 SP1
From an advisory covering 2 CVEs
before 3.0.31-bp152.2.3.1
3.0.31-bp152.2.3.1
zabbix
SUSE:Package Hub 15 SP2
From an advisory covering 2 CVEs
before 3.0.31-bp152.2.3.1
3.0.31-bp152.2.3.1
zabbix
openSUSE:Leap 15.1
From an advisory covering 2 CVEs
before 3.0.31-bp152.2.3.1
3.0.31-bp152.2.3.1
zabbix
openSUSE:Leap 15.2
From an advisory covering 2 CVEs
before 3.0.31-bp152.2.3.1
3.0.31-bp152.2.3.1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubycseo-git/CVE-2020-118002026-05-06

History

History
RecordedChangedSources
affected, facts
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2020-11800 is a critical vulnerability (CVSS 9.0) in Zabbix, published October 4, 2020. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 9.19%, the 95th percentile. Fixed in zabbix 1:4.0.0+dfsg-1.

References

Show 18 moreShow less
MoveEnter Open